Password sync doesn't work on non-Firefox-trunk builds

RESOLVED WORKSFORME

Status

Cloud Services
General
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Mardak, Unassigned)

Tracking

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
I get these warnings when syncing from Shiretoko:
2009-03-11 17:52:42     FaultTolerance       DEBUG
Original exception: Could not convert JavaScript argument arg 0 [nsISupports.QueryInterface] (JS frame :: weave/modules/engines/passwords.js :: PasswordStore__getAllIDs :: line 140)

It's trying to QI to nsILoginMetaInfo, but that only landed recently.

Good thing though is that bug 467463 is blocking 1.9.1+ so it should make it to Shiretoko.

Updated

9 years ago
Duplicate of this bug: 481547
(Reporter)

Updated

9 years ago
Blocks: 468694
(Reporter)

Updated

9 years ago
Duplicate of this bug: 482090

Comment 3

9 years ago
No plans to fix this for <=3.0, so closing as wontfix.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

9 years ago
WFM! Firefox 3.1 beta 3 :) The min requirements for weave should be b3.
Resolution: WONTFIX → WORKSFORME

Comment 5

9 years ago
ah yes, modded that locally and hadn't committed.  Pushed now:

http://hg.mozilla.org/labs/weave/rev/6a5e5ccca414

Updated

9 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
Version: Trunk → unspecified
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.