After launching modal dialog2 from modal dialog1, closing dialog1 returns focus to wrong window

VERIFIED DUPLICATE of bug 22658

Status

()

Core
Editor
P4
major
VERIFIED DUPLICATE of bug 22658
18 years ago
16 years ago

People

(Reporter: Lakespur Roca, Assigned: saari (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

(Reporter)

Description

18 years ago
build: 2000-08-09-09m18

Reproduce
incert an anchor opening a naming dialog 
select advanced button
Close or OK advanced dialog
Close or OK nameing dialog
The application brings a browser window into focus

The application should return you to the document and component you were working 
in.

Comment 1

18 years ago
using the m18 build from 8/10, I can reproduce this on win98, assigning to 
cmanske for review -- Charley please reassign to teh appropriate person if this 
is not your area.
Assignee: beppe → cmanske
Keywords: correctness, nsbeta3
Priority: P3 → P4
Whiteboard: [nsbeta3+][p:4]
Target Milestone: --- → M18

Comment 2

18 years ago
This seems to be true for any use of "Advanced Edit" dialog, such as from
the link, image, and table properties dialogs. Whenever "Advanced Edit" is 
used, closing the parent dialog returns to the wrong window.
Spell checking also has layered dialogs: Bring up spell checker, then use the 
"Edit..." button for the dictionary dialog, then close both. You will see the
focus shift to the browser window briefly, but then pull back to Composer!
The reason is that we explicitly call "window._content.focus();" after 
spelling. I could add that for all calls to our dialogs, but that seems
pretty lame. The shifting window focus is ugly anyway.
This is a general window focusing issue, not an editor bug. We should be able
to maintain parent window relationships for multiple levels of dialogs.
Removing [p:4], as we can't be sure of that yet!
Assignee: cmanske → saari
Severity: normal → major
Summary: Adding an anchor to a table brings browser window to front → After launching modal dialog2 from modal dialog1, closing dialog1 returns focus to wrong window
Whiteboard: [nsbeta3+][p:4] → [nsbeta3+]

Comment 3

18 years ago
Adding me to cc list and clearing m18
Target Milestone: M18 → ---
(Assignee)

Comment 4

18 years ago
Dup of 22658


*** This bug has been marked as a duplicate of 22658 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
verified in 8/16 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.