If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 471499
9 years ago
9 years ago

People

(Reporter: patrickjdempsey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2

A slight motion of the tab causes it to tear off and make a new window.  This becomes annoying when attempting to rearrange tabs or simply when you are clicking on the tab and you move the mouse slightly.  Simply the act of quickly selecting a tab while the mouse is still moving causes the tab to make a new window.  Proximity to the New Tab button also commonly causes the last tab to tear off because of moving the mouse in an attempt to actually hit the small target of the New Tab button instead of the tab, or the tab closer.  I've also encountered the issue while attempting to close a tab and it tears off instead of closes.

Reproducible: Always

Steps to Reproduce:
1. Select a tab with the mouse.
2. Move the mouse cursor ever so slightly in any direction while holding down the left button.


Expected Results:  
I would expect the tear off behavior to ONLY happen when the tab is moved off of the window plane, or in full-screen mode, when the tab is dragged to the edge of the screen.  

Don't get me wrong, I love the new feature, just not the way that it is currently implemented.  What makes this behavior especially annoying is the fact that it is far easier to accidentally tear a tab off into a new window than it is to get it back!  I'm sorry if this bug already exists, I did browse through a few pages of bugs and didn't find this specific one.

Comment 1

9 years ago
This is fixed in Firefox 3.1b3, please go to Help -> Check for updates.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 471499
You need to log in before you can comment on or make changes to this bug.