Make the pop-up blocker's text field more visible in the nib

RESOLVED FIXED

Status

Camino Graveyard
Annoyance Blocking
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Smokey Ardisson (offline for a while; not following bugs - do not email), Assigned: Christopher Henderson)

Tracking

Details

(Whiteboard: l10n [will need nib resaved on 10.4])

Attachments

(2 attachments)

1.33 KB, patch
Smokey Ardisson (offline for a while; not following bugs - do not email)
: review+
Stuart Morgan
: superreview+
Details | Diff | Splinter Review
5.37 KB, application/zip
Details
In bug 483033 we just saw a reoccurrence of an old problem (we saw it in 1.5 as well) where the text field in the pop-up blocker overlaps the leftmost button, often significantly.  When I was attempting to figure out what was wrong, it took me quite a bit of time being stumped, and only after I finally ran the interface simulator and noticed some "fuzzy" stuff on top of the button did I realize the problem was the overlap.

Unfortunately, this is extremely easy to miss because the text field uses grey text (looks great on our black gradient) and the color of the nib background is also grey.

Is there some way that we can either 

1) change the color of the text in the nib to provide contrast with the background, but then set the grey color we desire from code at runtime, or
2) add some sort of dark background to the nib that's ignored/drawn over by our gradient-drawing code?

If there's nothing we can do, so be it, but if there is a way, doing so would make it much easier for l10n teams to notice this problem and keep us from shipping it.
cl said the other day that doing 1) should be fairly easy (or at least possible), so I'm going to confirm this.  Won't block on this, but if someone has a few cycles to implement it, I'd be grateful.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: camino2.0b3?
Whiteboard: l10n [good first bug]
(Assignee)

Comment 2

9 years ago
Created attachment 376387 [details] [diff] [review]
Fix v1.0

Programmatically sets the text colour of the popup blocked label to 90% gray, the same as was in the nib.
Assignee: nobody → trendyhendy2000
Status: NEW → ASSIGNED
Attachment #376387 - Flags: review?(cl-bugs-new)
(Assignee)

Comment 3

9 years ago
Created attachment 376388 [details]
New PopupBlockView.nib

New PopupBlockView nib, with the label text colour changed to pure black. No other changes made. I can resave the nib in 10.4 this weekend, which will probably be before the patch passes sr.
(Assignee)

Updated

9 years ago
Whiteboard: l10n [good first bug] → l10n [will need nib resaved on 10.4]

Comment 4

9 years ago
Comment on attachment 376387 [details] [diff] [review]
Fix v1.0

Preemptive sr=smorgan on code. Someone should still do a sanity test though.

Do we care about the 10.5-itude of this nib? I'm inclined to think not, since it's loaded on demand.
Attachment #376387 - Flags: superreview+
Comment on attachment 376387 [details] [diff] [review]
Fix v1.0

Nib+patch passes sanity-check.

Since this isn't in a critical perf path on the tinderbox or in real usage (e.g., prefs), I'll go ahead and land this one.
Attachment #376387 - Flags: review?(cl-bugs-new) → review+
Checked in on cvs trunk.  Thanks for this fix, hendy!
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Flags: camino2.0b3?
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.