[bn-BD] Bengali, Bangladesh: Thunderbird Localization

RESOLVED FIXED

Status

Mozilla Localizations
Registration & Management
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Jamil Ahmed, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7
Build Identifier: 

* Product to localize: Mozilla Thunderbird 3.0
* languagecode-NATIONCODE: bn-BD (Bengali, Bangladesh)
* Name: Jamil Ahmed
* E-mail: itsjamil@gmail.com


Reproducible: Always
(Reporter)

Comment 1

8 years ago
Created attachment 367194 [details]
Bengali Bangladesh (bn-BD) Translation source tree

Please check. The output of compare-locales is:

bn-BD-src-13mar09:
keys: 1888
unchanged: 277
changed: 7409
96% of entries changed
Attachment #367194 - Flags: review?(l10n)

Comment 2

8 years ago
Comment on attachment 367194 [details]
Bengali Bangladesh (bn-BD) Translation source tree

Simon, can you have a look?

Note, we've landed bn-BD for fx on both 1.9.1 and central, so you probably want to check for differences against that in toolkit.
Attachment #367194 - Flags: review?(l10n) → review?(bugzilla)
Comment on attachment 367194 [details]
Bengali Bangladesh (bn-BD) Translation source tree

Looks good. Please land this in hg and file a followup bug in the "Build Config" component of the "Thunderbird" product here in Bugzilla to get bn-BD added to mail/locales/all-locales (which will give you dashboard coverage and regular nightly builds for testing).
Attachment #367194 - Flags: review?(bugzilla) → review+

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Jamil, just wanted to check back. Anything unclear in my earlier comment (comment 3)? If not, let me know when you are able to proceed. Thanks!
Assignee: nobody → itsjamil
Status: NEW → ASSIGNED
(Reporter)

Comment 5

8 years ago
Simon, I thought Axel will do both landing in hg as I don't have any access yet and also file the bug? :)

Comment 6

8 years ago
Moving this to Registration, as that's more like it.

Jamil, I just moved your account bug to IT, so you should be able to land yourself soon. Feel free to poke in #l10n for help for your initial landing.

Not sure if I said this elsewhere yet, but the repo that's of real interest to you right now is http://hg.mozilla.org/releases/l10n-mozilla-1.9.1/bn-BD/. You should be able to already clone that and check-in locally. Once your ssh access is there, add a default-push path to .hg/hgrc with ssh: instead of http:, and push your changes upstream.
Assignee: itsjamil → registration
Component: bn-BD / Bengali → Registration & Management
QA Contact: bengali.bn-bd → registration
(Reporter)

Comment 7

8 years ago
I have just pushed Thunderbird's bn-BD source to hg. Can someone please check if it is ok or not? :)
(Reporter)

Comment 8

8 years ago
Simon, I have submitted a followup bug #484184 as you advised. Thanks.
(Reporter)

Comment 9

8 years ago
I did not find bn-BD packages in the nightly builds of Thunderbird. Any help please?

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central-l10n/
Jamil, since the bn-BD locale is currently red because of missing strings. 

See http://l10n.mozilla.org/dashboard/?tree=tb30x&locale=bn-BD for the rednes. 
See http://l10n.mozilla.org/buildbot/compare/hg-comm-langpack/17876 for the list of missing strings
This bug is FIXED with the checkin for bug 484184.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.