lost 'last open tabs' if closing firefox with open download manager

RESOLVED DUPLICATE of bug 354894

Status

()

--
major
RESOLVED DUPLICATE of bug 354894
10 years ago
10 years ago

People

(Reporter: l.klesal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7

I'm used to have a lot of tabs open in my browser.
I have only one instance of firefox open.
When i close the browser, i always want to save my open tabs.. and so i do.. So i click on the button 'save and exit'

When i accidentally have a download manager open at the time of the exiting procedure.. I will lose my open tabs on the next start... Even if i clicked to save my open tabs.. 

On the next start only my default starting pages appear

I love tabs and i hate loosing them.. it's always hairtearing experience for me when the browsers starts only with my default tabs...

Reproducible: Always

Steps to Reproduce:
1. I have set 4 pipe separated default home-pages http://www.sciencedaily.com/|http://www.yatzer.com/|http://www.designspotter.com/|http://en.eyeka.com/  in my browser
2. I usually work with 20-30 tabs open
3. I download something from time to time.. so my download manager pops-up
4. I close my browsing.. selecting to save my open tabs and accidentally leaving my download manager open at the time of exit
5. the browser closes
6. I close the download manager afterwards
7. I start firefox again.. hoping to see my last tabs
8. Only my default 4 tabs open..
9. I yell..
Actual Results:  
Only default homa-page tabs will open..

Expected Results:  
All of my saved tabs will open

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 354894
You need to log in before you can comment on or make changes to this bug.