Closed Bug 483327 Opened 12 years ago Closed 12 years ago

Options window is too tall after the landing of bug 390734

Categories

(Firefox :: Preferences, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 3.5b4

People

(Reporter: robert.strong.bugs, Assigned: robert.strong.bugs)

Details

(Keywords: fixed1.9.1, late-l10n, Whiteboard: [polish-easy][polish-visual][polish-p3])

Attachments

(2 files, 1 obsolete file)

bug 390734 reduced the padding and margin used by groupboxes and now there is some extra room in the options pref window.

I'm going to also fix a bug with animateFadeIn=true on Windows where the tabpanel bottom border isn't displayed.
Attached patch patch rev1 (obsolete) — Splinter Review
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Attachment #367324 - Flags: review?(mconnor)
Attached image screenshots
Whiteboard: [polish-easy][polish-visual]
Keywords: late-l10n
Dao: can you take this review?
Attachment #367324 - Flags: review?(dao)
Comment on attachment 367324 [details] [diff] [review]
patch rev1

This seems to make the window too small over here:

1. open the Options window
2. select "Content"
3. close the Options window
4. open the Options window
5. select "General"

-> the window gets taller
Attachment #367324 - Flags: review?(dao) → review-
Comment on attachment 367324 [details] [diff] [review]
patch rev1

>+/* Advanced Pane */
>+#advancedPrefs {
>+  padding-bottom: 8px;
>+}

And this could use a more useful comment :)
It's pretty clear that it's about the Advanced pane, but it's not obvious what you're doing there, and why.
Which windows version / theme are you using. With or without animateFadeIn?

No problem adding a comment about why but I want to keep the section header since that seems to be the standard in this file so people can tell what prefpane it refers to... makes it easier for those that don't work with this file often.
The STR didn't show a problem for me on Vista.

Can I see a screenshot?
Also wasn't able to reproduce on Vista with Classic.
Windows XP, Luna, animateFadeIn=false. Sure you need a screenshot? Opening the window with a pane other than "General" and switching to "General" makes the window taller -- not much to see otherwise.
The difference is 9 pixels... from 434 to 443.
Attached patch patch rev2Splinter Review
Thanks Dao
Attachment #367324 - Attachment is obsolete: true
Attachment #368330 - Flags: review?(dao)
Attachment #367324 - Flags: review?(mconnor)
Attachment #368330 - Attachment is patch: true
Attachment #368330 - Attachment mime type: application/octet-stream → text/plain
Attachment #368330 - Flags: review?(dao) → review+
Attachment #368330 - Flags: approval1.9.1?
Comment on attachment 368330 [details] [diff] [review]
patch rev2

Requesting 1.9.1 before landing on trunk since this affects l10n
Comment on attachment 368330 [details] [diff] [review]
patch rev2

a191=beltzner
Attachment #368330 - Flags: approval1.9.1? → approval1.9.1+
Rob: you gonna check this in?
Pushed to mozilla-1.9.1
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/861150b48c0d

I'll push this to mozilla-central once the tree is green
Keywords: fixed1.9.1
Pushed to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/b59984b88601
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.5b4
This bug's priority relative to the set of other polish bugs is:
P3 - Polish issue that is in a secondary interface, occasionally encountered, or is not easily identifiable.
Whiteboard: [polish-easy][polish-visual] → [polish-easy][polish-visual][polish-p3]
You need to log in before you can comment on or make changes to this bug.