SOCKS: intermittent 'connection refused' errors

VERIFIED FIXED in Future

Status

()

Core
Networking
P3
normal
VERIFIED FIXED
18 years ago
16 years ago

People

(Reporter: e9026662, Assigned: Gagan)

Tracking

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
when browsing pages i frequently get 'connection refused' messages.
i think it has something to do with the use of a socks proxy because
i don't get these messages when i disable proxy usage.

my socks proxy settings are:
host: proxy.tuwien.ac.at       port: 1080

Comment 1

18 years ago
e9026662@student.tuwien.ac.at can you please take a look at the bug writing
guidelines to see the kinds of information thatt helps us process your issue
efficiently.  http://www.mozilla.org/quality/bug-writing-guidelines.html
What build did you test this on.  How frequently were you able to make a
connection?  
(Reporter)

Comment 2

18 years ago
to be more specific: i tested this on the m17 browser component;
i don't know if it has something to do with it, but i noticed that
behaviour on pages with lots of advertising banners.
(e.g. www.ipo.com, www.bigcharts.com); on www.ipo.com, for example, i get
3-5 'connection refused' messages per page

maybe it's got something to do with the banners being served from a
different domain than the pages themselves...

sorry for being sloppy on the first take,
patrick

Target Milestone: --- → M17

Comment 3

18 years ago
adding justin who made socks happen for us.  

Comment 4

18 years ago
*** Bug 49718 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
Reporting comments from dupe bug 49718: Socks proxy causes weird "connection
refused" messages

I was trying to use Mozilla M17 from work on my linux box, it works fine with
our http proxy (though our http proxy is dog slow and only works for parts of
the day), but with socks it says connection refused constantly.  Especially when
submitting forms (but not exclusively, this may be a red herring). 
Unfortunately our socks is the only fast one.  I had this same problem on Win 2k
with Netscape 6.0 PR2.  The same socks proxy works fine with the most recent
Communicator for both Linux and Win 2k.  I cant wait for mozilla to get this
fixed and java support for both linux and windows up to spec, then life will be
really good....  

In the log it would just say error connecting.  Sometimes that would happen even
though it loaded the page.

Comment 6

18 years ago
over to networking
Assignee: asa → gagan
Component: Browser-General → Networking
QA Contact: doronr → tever

Comment 7

18 years ago
I'm seeing too this messages, but I do not use any proxy (the proxy is
autoconfigurated at my provider). Not all time, but I also see it using
win98/me/2000.

Now i'll try to find how to reproduse it.

Removing milestone (M17 is out for a mounth).
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Target Milestone: M17 → ---
(Assignee)

Updated

18 years ago
Target Milestone: --- → Future

Comment 8

17 years ago
I'd like to look at this problem further, but I need more information:

1- If this is happening to you still, please update this bug and let us know.
2- If you can give us the URL to a page that gets these problems, please add it
here.
3- If we can test with your SOCKS server, please let us know.

This and the linked duplicate are the only report of the problem, so I am
unconvinced this is a broad problem for mozilla users.

Comment 9

17 years ago
I still get this problem.  With the latest build downloaded on the morning of
3-19-2001, I can't get through my firewall to *anywhere* while Communicator
4.76 connecting through the same server reports no errors.  I'm sorry but I
have no control over our internal servers.

Oh, and Mozilla (on Linux) spit out:
Error loading URL http://lwn.net/daily/: 804b000d

Comment 10

17 years ago
changed summary: to reflect that this bug is about partial failures in SOCKS.

Summary: frequent 'connection refused' messages when connecting through a socks proxy → SOCKS: intermittent 'connection refused' errors

Comment 11

17 years ago
qa to me.
QA Contact: tever → benc
There is a timeout problem connecting to a proxy server which is not local. This
has been fixed in 65583, which has a patch ready, but hasn't been checked in yet.
Should be fixed by fix for bug 65583.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 14

16 years ago
VERIFIED: nobody has reported this in a long time. (strangely, our proxy server
is really overloaded (Sparc 20), but did not have this problem...)
Status: RESOLVED → VERIFIED
Depends on: 65583
You need to log in before you can comment on or make changes to this bug.