If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

UTF-8 encoding of Subject line of event invitation email gets wrong if non-ASCII characters present

VERIFIED DUPLICATE of bug 482131

Status

Calendar
E-mail based Scheduling (iTIP/iMIP)
VERIFIED DUPLICATE of bug 482131
9 years ago
9 years ago

People

(Reporter: David von Oheimb, Unassigned)

Tracking

Lightning 0.9
All
Linux

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.7) Gecko/2009030422 Ubuntu/8.04 (hardy) Firefox/3.0.7
Build Identifier: Lightning 0.9 (build 2008091718)

If the subject of an event invitation contains non-ASCII characters (e.g. umlauts), the whole Subject line, including the word "Subject: " of the resulting email get UTF-8 encoded, which makes the Subject info "invisible" and corrupts the rest of the email.

Reproducible: Always

Steps to Reproduce:
1. Send out an invitation that contains non-ASCII characters in the title

Actual Results:  
The whole Subject line of the resulting email gets UTF-8 encoded

Expected Results:  
On the the actual subject text (behind the Subject: prefix) should be encoded
(Reporter)

Updated

9 years ago
Duplicate of this bug: 483585
(Reporter)

Updated

9 years ago
Version: unspecified → Lightning 0.9

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 482131

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.