Add icon in ChatZilla menu item in Tools pull down menu.

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
10 years ago
10 years ago

People

(Reporter: pander, Assigned: rginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.7) Gecko/2009030422 Ubuntu/8.10 (intrepid) Firefox/3.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.7) Gecko/2009030422 Ubuntu/8.10 (intrepid) Firefox/3.0.7

Add icon in ChatZilla menu item in Tools pull down menu. See also http://launchpadlibrarian.net/20320651/screenshot.png and https://bugs.launchpad.net/ubuntu/+bug/243466

Reproducible: Always

Comment 1

10 years ago
Menu icons are not required for add-ons. In fact, none of the default menus in Firefox use icons, except for the bookmark menu, for the sole purpose of being able to show favicons. Adding icons makes the menu wider for no real purpose (since none of the builtin stuff has icons).

Going with WONTFIX here. Feel free to reopen if you think there are very good reasons why we should do this (you didn't give any in your original report).
Severity: trivial → enhancement
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

10 years ago
As you can see here http://launchpadlibrarian.net/23911111/tools-menu.png the Error Console, Page Info and Clear Private Data, which all are default in Firefox, use icons. also View, Edit, File and Help menu have icons (Firfox on Ubuntu Linux).

For me, personally, I don't care of you add them or not. Just wanted to bring to the attention that when it is customary to add an icon there, ChatZilla is lacking one. ChatZilla maintainers can decide what they want to do with this info.

Comment 3

10 years ago
Created attachment 367585 [details]
Firefox Tools Menu on Vista

I'd say this is actually a reasonable idea, I've attached a screenshot of the tools menu in firefox on vista - as you can see there's a nice space where the icon would go.

I should note that even on menus without icons for any of the items, the gutter area is still displayed (its where the ticks go for toggleables)

Comment 4

10 years ago
For Windows Firefox, this is definitely a WONTFIX - only favicons appear in any of the menus. Linux Firefox appears to like menu icons, but putting ChatZilla's icon there only on one platform would be both hard and inconsistent, so this is staying WONTFIX for now.
You need to log in before you can comment on or make changes to this bug.