Last Comment Bug 483589 - PRBool problem in nsHTMLEditor::EnableExistingStyleSheet
: PRBool problem in nsHTMLEditor::EnableExistingStyleSheet
Status: RESOLVED FIXED
: fixed1.9.1
Product: Core
Classification: Components
Component: Editor (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: mozilla1.9.2a1
Assigned To: Graeme McCutcheon [:graememcc]
:
: Makoto Kato [:m_kato]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-16 04:38 PDT by (dormant account)
Modified: 2009-04-10 02:12 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix [Checkin: Comment 2] (1.01 KB, patch)
2009-03-16 13:15 PDT, Graeme McCutcheon [:graememcc]
peterv: review+
peterv: superreview+
dbaron: approval1.9.1+
Details | Diff | Splinter Review

Description (dormant account) 2009-03-16 04:38:24 PDT
Error: /editor/libeditor/html/nsHTMLEditor.cpp:
 3697 & 3705:   NS_ENSURE_SUCCESS(rv, rv);

http://mxr.mozilla.org/mozilla-central/source/editor/libeditor/html/nsHTMLEditor.cpp#3705

See Taras' blog for more info about prbool bugs
http://blog.mozilla.com/tglek/2008/11/07/enabling-prcheck-email-notifications/#respond


bug 432114 is the last mod to that code, but I think the problem was there before.
Comment 1 Graeme McCutcheon [:graememcc] 2009-03-16 13:15:23 PDT
Created attachment 367641 [details] [diff] [review]
Fix
[Checkin: Comment 2]
Comment 2 Serge Gautherie (:sgautherie) 2009-03-18 09:15:45 PDT
Comment on attachment 367641 [details] [diff] [review]
Fix
[Checkin: Comment 2]


http://hg.mozilla.org/mozilla-central/rev/3499bad5d5ce
Comment 3 Ed Lee :Mardak 2009-03-31 16:53:31 PDT
Curious, any particular reason for switching to if (NS_FAILED) which doesn't warn in debug builds instead of just using NS_ENSURE_SUCCESS(rv, PR_FALSE);
Comment 4 David Baron :dbaron: ⌚️UTC-10 (vacation, returning December 19) 2009-04-02 13:16:54 PDT
Comment on attachment 367641 [details] [diff] [review]
Fix
[Checkin: Comment 2]

a1.9.1=dbaron
Comment 5 Robert O'Callahan (:roc) (email my personal email if necessary) 2009-04-10 02:12:39 PDT
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/b37de4254e14

Note You need to log in before you can comment on or make changes to this bug.