XML Parsing Error when loading this page (works in Firefox 3.0.7)

VERIFIED FIXED in mozilla1.9.2a1

Status

()

defect
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({regression, testcase, verified1.9.1})

1.9.1 Branch
mozilla1.9.2a1
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9.1 +
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 478889], )

Attachments

(1 attachment)

409 bytes, application/xhtml+xml
Details
Reported from a Hendrix user:

STR:
1. Load the page listed in the URL

Actual: XML Parsing error
Expected: Page would load normally as it does in FF 3.0.7 with no errors
Flags: blocking1.9.1?
(In reply to comment #1)
> dupe of bug 478889?

Lets ask Boris, but at least in the code of the given web page I cannot see a deferred attribute.
The regression range is the same as for bug 478889.  That said, I don't see any deferred scripts here either (including via setting the relevant breakpoints in nsScriptLoader).

That said, the last patch in bug 478889 does seem to fix it.  Let's leave it dependent for now, dup if the patch that lands fixes it.
Depends on: 478889
Flags: blocking1.9.1? → blocking1.9.1+
Whiteboard: [fixed by 478889?]
This works for me now with latest m-c (i.e. with the patch for bug 478889).
Great.

Would be really nice to have a testcase, of course... :)
Status: NEW → RESOLVED
Closed: 10 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
(In reply to comment #6)
> Would be really nice to have a testcase, of course... :)

Martijn, would you mind (if you have time)?

Verified fixed with builds on OSX and Windows: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090318 Minefield/3.6a1pre ID:20090318052249
Status: RESOLVED → VERIFIED
OS: Mac OS X → All
Hardware: x86 → All
Target Milestone: --- → mozilla1.9.2a1
Posted file testcase
Sorry for the delay, it turns out this is causing a parser error before this bug was fixed.
Martijn, do you think you can make this into a reftest or mochitest?
Yes, will do. Sorry, I still have a backlog of other things to do.

Updated

10 years ago
Duplicate of this bug: 488105
Pretty clear that this was fixed on branch, marking it. Obviously it would still be good to get the mochi/reftest, but I don't think this needs to show up on the blocker report any more.
Keywords: fixed1.9.1
Whiteboard: [fixed by 478889?]
Verified fixed on 1.9.1 with builds on OS X and Windows:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b5pre) Gecko/20090513 Shiretoko/3.5b5pre ID:20090513034609
Whiteboard: [fixed by bug 478889]
You need to log in before you can comment on or make changes to this bug.