Copy of non-breaking space from form field pastes a space

RESOLVED DUPLICATE of bug 359303

Status

()

Core
Editor
RESOLVED DUPLICATE of bug 359303
10 years ago
4 years ago

People

(Reporter: Jakub Vrána, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729)

If the form field (input, textarea) contains a non-breaking space (U+00A0, Alt+0160 on Windows) and user copies the contents of the form field, a common space (U+0020) is pasted instead. This is true if the contents is written as   and also as a Unicode character.

Reproducible: Always

Steps to Reproduce:
1. <input name="x" value="&nbsp;"> or <input name="x" value=" ">
2. Copy the value of the input.
3. Paste it anywhere.
Actual Results:  
Space is pasted.

Expected Results:  
Non-breaking space is pasted.

Updated

10 years ago
Component: General → Editor
Product: Firefox → Core
QA Contact: general → editor

Comment 1

8 years ago
Related to/duplicate of Firefox bug 359303?

Comment 2

7 years ago
Definitely duplicate of bug 359303

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 359303
You need to log in before you can comment on or make changes to this bug.