Closed Bug 484037 Opened 12 years ago Closed 11 years ago

Nokia n800 D-Pad center button submits forms instead of magnifying the on-screen keyboard

Categories

(Firefox for Android Graveyard :: General, defect)

Other
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: robert.russell, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Build Identifier: Mozilla Fennec 1.0b1

On the Nokia n800 internet tablet, the device has a 4-way D-pad in the upper-left corner, as pictured here: http://pocketables.typepad.com/photos/uncategorized/2007/08/16/nokia_n800_controls1.jpg

The center button of this directional pad is used for two functions:
   1.) When the On-Screen Keyboard IS NOT active, this button acts as an Enter key, effectively clicking on a link or otherwise activating a selected item.
   2.) When the On-Screen Keyboard IS active, this button toggles between the stylus-optimized on-screen keyboard and the finger-optimized on-screen keyboard.

Pictures of the two on-screen keyboards are:
Stylus-optimized: http://www.nokiaphoneblog.com/images/n800-connections.jpg
Finger-optimized: http://www.blogcdn.com/www.engadget.com/media/2007/01/nokia-n800-review.jpg

In running Mozilla Fennec 1.0b1 on my n800, Fennec is not accepting functionality #2.  If I am entering text with the stylus-optimized on-screen keyboard in to a website form, and press the D-Pad center button, I find that Fennec interprets this as a command to submit the form.  Fennec should instead toggle to the finger-optimized on-screen keyboard.

On the bright side, I found that Fennec handles this button correctly when I am typing in the awesomebar.  The misinterpretation of the button press happens only when typing in text boxes found on website forms.

This bug, especially in combination with the other on-screen keyboard bug https://bugzilla.mozilla.org/show_bug.cgi?id=480306 make it impossible to use Fennec for any authentication-required websites with a Nokia n800 that does not have a bluetooth keyboard.

Reproducible: Always

Steps to Reproduce:
1. Open website with HTML form
2. Select in a textarea to bring up on-screen keyboard
3. Press D-Pad center button to toggle to finger-optimized on-screen keyboard

Actual Results:  
4. FAIL: Form is submitted.

Expected Results:  
4. WIN: Fennec should bring up the Maemo finger-optimized on-screen keyboard.
I have been on a N810 and this isn't possible.  I see how it is possible with the N800 though.
(In reply to comment #1)
> I have been on a N810 and this isn't possible.  I see how it is possible with
> the N800 though.

yeah, on n810 it is not possible to use D-PAD "enter" to toggle between finger and stylus-enabled vkb , once on n810 DPAD enter is only available when physical keyboard is slided down , so no vkb can show up ...

> Steps to Reproduce:
> 1. Open website with HTML form
> 2. Select in a textarea to bring up on-screen keyboard
> 3. Press D-Pad center button to toggle to finger-optimized on-screen keyboard

> Actual Results:  
> 4. FAIL: Form is submitted.

> Expected Results:  
> 4. WIN: Fennec should bring up the Maemo finger-optimized on-screen keyboard.

reporter, please double check if you have the proper settings for that to happen:

iirc, go to menu -> settings -> control panel -> text input settings ->  on-screen (tab) ... and there will be an options about what you want

hum, also, not sure it if is MAJOR, since behavior is-to-be-defined and bug is in UNCONFIRMED state. 

ui-wanted ?
I have confirmed the settings:  -> Settings -> Control Panel -> Text Input Settings -> "Launch Finger Keyboard with (icon for D-pad center button):" -> Checked.

However, now that I'm using Fennec/1.0b2 (Gecko 20090626), the D-pad center button is working correctly, and it's toggling between stylus and finger on-screen keyboards.  (Hooray!)

Unfortunately, the content of the text field is not passed from the stylus keyboard to the finger keyboard, only vice-versa.  This may justify a new bug number, I'm not sure.

Here's the steps in Fennec:
1. Go to http://www.google.com/search?q=foo
2. Page loads, with search field pre-populated with text "foo"
3. Select the text input box, use stylus keyboard to append "bar" so that the text reads "foobar"
4. Toggle to finger keyboard, the displayed input buffer is blank.
5. Type "baz" and toggle back to stylus keyboard
6. The "baz" text is now appended to "foobar" and appears as "foobarbaz"

However, if I follow the same steps in the Maemo OS2008 default browser, then step 4 copies the stylus keyboard's input buffer over to the finger keyboard, so that in step 5, I can backspace over "bar" and end up with "foobaz".

To provide some more detail, I've found in Fennec that whenever I switch back from the finger keyboard, the text is moved in to the input field and the finger keyboard'd buffer is cleared.  Thus, I can't return to the finger keyboard to edit the text later.

Please let me know if I should open a new bug, or if this older bug should be left open.
Severity: major → normal
Stuart are we supporting this device anymore?
(In reply to comment #4)
> Stuart are we supporting this device anymore?
Please do! I use Fennec nightlies on my n800 and aside from small glitches it works perfectly. Aside from lack of the physical keyboard n800 it's technically identical to n810.
I can also confirm what's described on comment #3
not a target
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.