IMAP Mails with attachments don't display until attachments fully download

VERIFIED FIXED

Status

MailNews Core
Networking: IMAP
P3
critical
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Peter Lairo, Assigned: Scott MacGregor)

Tracking

({perf})

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
mail with attachment didn't display.

i received a normal mail with a M$ word doc ttached (30k). when i select the
subj line it says "loading document..." forever.

i get my mail from compuserve imap.cs.com.

other mails are ok. when i open this mail in nC4.74, it displays ok (5 secs)

Comment 1

18 years ago
dup of 48374?

*** This bug has been marked as a duplicate of 48374 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Blake - not sure if a duplicate.  Duplicate bug states that the attachment is 
not recognized. This bug says that the entire mail msg is always showing 
"loading document"
QA Contact: lchiang → pmock

Comment 3

18 years ago
Yeah, I don't think so either. Both this and bug 48374 are unclear...Peter, 
could you explain more about the problem, and give the build ID, please?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

18 years ago
here's the info:

Mozilla M17 Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m17) Gecko/20000807

Comment 5

18 years ago
Peter Lairo, are you still seeing this with current nightly builds.
PLairo@cs.com, this WORKSFORME in 20001020, Win95. If you are still seeing this 
bug in nightly builds, please report back, otherwise we'll close this bug.

Gerv
However, mail with attachments doesn't display until the attachments have been 
downloaded. For people on slow connections, this is very bad. I'm in a LAN and 
1.2Mb of attachments took about 2 minutes to download, so either my mail server 
is slow or Moz is doing this very slowly anyway.

This won't make rtm, probably, but it's still totally the wrong behaviour.

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: perf
Summary: mail with attachment didn't display → IMAP Mails with attachments don't display until attachments fully download

Comment 8

18 years ago
There is a feature called "mime parts on demand" which loads the msgs, but not
the attachments until you click on the attachment icon.  See
http://bugzilla.mozilla.org/show_bug.cgi?id=41569 for a description.  The
default is on for new profiles.
MPOD does not seem to be turned on for new profiles, or imported ones, so I've 
reopened the relevant bug. I have to wait three minutes to see the small text 
body of a message with a 3Mb attachment.

Gerv

Comment 10

18 years ago
MPOD is turned on for new profiles, as I think we've fully established in other
bug reports. However, we do download inline attachments, and attachments we can
render inline, like .html (and we did this in 4.5). My guess is that this is
fixed and should be closed.

Comment 11

18 years ago
is there any reason to keep this bug open?
(Reporter)

Comment 12

18 years ago
if you fixed it, close the bug and move on :-)

Comment 13

18 years ago
OK, I'll mark it works for me. It's probably a dup 
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
VERIFIED FIXED, I've had no problems (as this bug describes), but others remain
in seperate filed bugs.
Status: RESOLVED → VERIFIED

Comment 15

17 years ago
*** Bug 72686 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.