[JavaScript Error: "this._storage is null"] error after resetting Master Password

NEW
Unassigned

Status

()

P5
normal
10 years ago
4 months ago

People

(Reporter: marcia, Unassigned)

Tracking

1.9.1 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [passwords:master-password])

Attachments

(2 attachments)

Seen while testing Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3

STR:
1. Running the Password Manager Full Functional Tests in Litmus, the last thing I did was reset my password using the chome command in the test case.
2. I have FIPS enabled. 

Receive this in the Error console: Error: uncaught exception: [Exception... "'[JavaScript Error: "this._storage is null" {file: "file:///Users/marcia/Desktop/Build2/Firefox.app/Contents/MacOS/components/nsLoginManager.js" line: 522}]' when calling method: [nsILoginManager::countLogins]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://browser/content/pageinfo/security.js :: realmHasPasswords :: line 315"  data: yes]
(Reporter)

Comment 1

10 years ago
Created attachment 368154 [details]
Error dialog after trying to reload pages

I also get this error dialog when going back to bugzilla and the mozilla wiki and cannot re-login in to these sites.
Could bug 479941 be related to this as well?
(Reporter)

Comment 3

10 years ago
Interesting re: https://bugzilla.mozilla.org/show_bug.cgi?id=479941#c7, since right before the Password Manager run I was testing Cookies, and had my start page set to about:blank.
Can you try reproducing this with debug logging enabled? https://wiki.mozilla.org/Firefox:Password_Manager_Debugging

It should be logging some more things before failing, which will narrow down what might be causing this.
(Reporter)

Comment 5

10 years ago
I think I may have narrowed down what is causing this.  I went back to the horked profile and disabled FIPs, and the sites that were problematic to load were then fine. I then followed these STR and was able to get in a horked state again:

1. Enable a master password and then enable FIPS (FIPS requires a Master Password)
2. Reset the Master password using chrome://pippki/content/resetpassword.xul command.
3. Receive errors such as The operation failed because the PKCS#11 token is not logged in.

(Error code: sec_error_token_not_logged_in)

As I said, if I then go in and disable FIPs then there is no issue with the sites having trouble loading.

Comment 6

10 years ago
Similar steps I tried:
1. Installed Shiretoko nightly
2. Turned on PM logging in the console, and restarted
3. Opened the Error Console
4. Set a master password
5. Enabled FIPS
6. Reset master password using chrome://pippki/content/resetpassword.xul

You will see this in the All tab:
Login Manager: Initialization of storage component failed: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIPK11Token.initPassword]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Program%20Files/Shiretoko/components/storage-mozStorage.js :: anonymous :: line 220"  data: no]

When I try to load https sites I get the page load error as in comment #1, and you'll see errors like the following in the Errors tab:

Error: this._storage is null
Source File: file:///C:/Program%20Files/Shiretoko/components/nsLoginManager.js
Line: 522
Created attachment 409273 [details]
Different error dialog

I get the same error in Comment 5 when testing the Firefox 3.6 beta candidate. I did have a master password set as well as FIPS enabled. With a bunch of sites loaded including paypal, I entered private browsing mode. I then got the attached dialog.
Whiteboard: [passwords:master-password]
You need to log in before you can comment on or make changes to this bug.