Closed Bug 484372 Opened 11 years ago Closed 11 years ago

TM: Crash when running Adblock Plus testcase [@js_Interpet - forced_return]

Categories

(Core :: JavaScript Engine, defect, P1, critical)

1.9.1 Branch
x86
Windows XP
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: gaubugzilla, Assigned: sayrer)

References

()

Details

Running the testcase given in the URL gives a consistent crash on Shiretoko:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090314 Shiretoko/3.1b4pre

Disabling JIT fixes the issue. Same testcase runs fine in Minefield. One of the crash reports: http://crash-stats.mozilla.com/report/index/e2dd8124-09c7-4f41-a54e-9f2172090320

The crash report points to this line (immediately following forced_return label):

  ok &= js_UnwindScope(cx, fp, 0, ok || cx->throwing);

Only possibility for an access violation here is a NULL cx from what I can tell.

I am not sure what in this testcase causes a crash, figuring that out will take some time.
I didn't realize that Shiretoko only updated to the next nightly rather than the newest build. Updated to build 20090319 now but it still crashes.
How do I run your mochitests?
Flags: blocking1.9.1?
does it work in 3.6a1pre (Minefield)?
(In reply to comment #2)
> How do I run your mochitests?

http://adblockplus.org/en/source#test has the instructions. I don't currently create builds with tests included, maybe something to change.

(In reply to comment #3)
> does it work in 3.6a1pre (Minefield)?

Yes, I said that in the bug description - that crash only occurs in 3.5b4pre (same profile).
probably will be fixed with a merge. stay tuned.
Flags: blocking1.9.1? → blocking1.9.1+
Priority: -- → P1
Assignee: general → sayrer
And ??
No longer crashes in build 20090408.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Probably bug 487271 et seq.

/be
You need to log in before you can comment on or make changes to this bug.