Drag and Drop History Items or Tag Folders to Bookmarks Toolbar Results in JS Exception

RESOLVED DUPLICATE of bug 509676

Status

()

RESOLVED DUPLICATE of bug 509676
10 years ago
10 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

3.5 Branch
x86
Linux
Points:
---
Bug Flags:
in-testsuite ?
in-litmus ?

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Build Id: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3 ID:20090305134136


When dragging and dropping a history item from the History SideBar and/or Library to any Bookmarks standard point (menu, library, toolbar, etc), the  item is not saved onto it and the following error shows up in the Error Console. This works fine on the latest 3.0 build and on OS X (on the same build).

Error: uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsINavBookmarksService.getFolderIdForItem]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: file:///home/mozilla/Desktop/b3/firefox/components/nsPlacesTransactionsService.js :: placesMoveItemTransactions :: line 547"  data: no]


Steps to Reproduce:
1. Open the History Sidebar or go to Show All History in the Library
2. Open the Error Console.
3. Drag and Drop a History item to any Bookmarks standard point (toolbar or menu).

Expected Results: 
There should be no JS exception and the history item should be added to the bookmarks standard point.
Flags: in-testsuite?
Flags: in-litmus?
(Reporter)

Updated

10 years ago
Summary: Drag and Drop History Item to Bookmarks Toolbar Results in JS Exception → Drag and Drop History Items or Tag Folders to Bookmarks Toolbar Results in JS Exception
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090317 Shiretoko/3.1b4pre

WFM on windows.
i can't reproduce this... could you try again or provide further informations to reproduce?
Is this Linux only?
I can reproduce on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090401 Minefield/3.6a1pre.

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 509676
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.