degraded and slow scroll rendering in ff 3.1b3 from ff 3.1b2

RESOLVED DUPLICATE of bug 479852

Status

()

Core
General
--
major
RESOLVED DUPLICATE of bug 479852
9 years ago
9 years ago

People

(Reporter: Mike, Unassigned)

Tracking

1.9.1 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3

Page scrolling on some pages has become substantially slower in ff 3.1b3.  I have retested these pages on ff 3.1b2 and the difference is immediately noticeable and consistent.  Scrolling on most pages appears fine, but I've included http://westseattleblog.com/blog/ as a good test case since many of the pages on this site suffer from the problem.

My setup:
ff 3.1b3
Enabled add-ons: Gmail Notifier, Pike's Clone Window
Hardware: 17" Macbook Pro (Final version pre unibody) Intel 2.4 Core 2 Duo, 4GB RAM
OSX Leopard 10.5.6
Using trackpad not mouse.


Reproducible: Always

Steps to Reproduce:
1. Navigate to http://westseattleblog.com/blog/ or http://westseattleblog.com/blog/?page_id=432
2. Scroll down

Actual Results:  
Page scrolling is choppy and delayed

Expected Results:  
Page scrolls reasonably smooth with performance similar to ff 3.1b2

Marking Severity to Major since to my eye the issue requires resolution prior to 3.1 release.
Do you also see a delay if you use the scrollbar?
On windows using the scrollbar I see a regression on 11 Sep 2008 but I don't know if this is the same bug. In case that it is the same bug: http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2008-09-11+10%3A00%3A00&enddate=2008-09-11+22%3A00%3A00
Component: General → General
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → 1.9.1 Branch
(Reporter)

Comment 2

9 years ago
I also see this delay using the scrollbar, but think it is a new issue since it is a difference between ff 3.1b2 and ff 3.1b3 (released 3/12/2009).
(Reporter)

Comment 3

9 years ago
The primary issue using http://westseattleblog.com/blog/?page_id=432 as a test case appears somewhere between the 12/26/2008 and 1/1/2009 nightly builds.  This page does not appear to contain embedded flash.  

At the time of viewing, the front page of this blog has embedded flash and somewhere between the 12/15/2008 and 12/20/2008 nightly builds, there is a noticeable lag while scrolling past embedded video players.

Performance problems from these two combined issues is substantial.
No, on Windows a Dec 2008 build and a Jan 2009 build give the same scroll delay so this is a not related issue I think..

Comment 5

9 years ago
On my 8-core 2008 Mac Pro with a fast ATI 3870 graphics card, the West Seattle Blog site exhibits no scrolling problems, but if I increase text size (Cmd-+), the scrolling is completely crippled! Also observed on sites such as

http://news.cnet.com/8301-17938_105-10203342-1.html?tag=xlr8yourmac

but NOT for sites like

www.macfixit.com.

The Profile-folder file "content-prefs.sqlite" stores this text-size info and a return to a site where the text size was changed long ago can exhibit paradoxical crippled scrolling. Recommended: Quit Firefox, delete this file, and reopen the offending site. If scrolling is fine, it's related heavily to the text-size issue. I hope this is fixed.
(Reporter)

Comment 6

9 years ago
Thanks for the tip.  Removing the content-prefs.sqlite file and bouncing firefox led to resolved scrolling.  I hope this is fixed too.  OSX isn't very good at specifying a larger default system font size so with the high res screen on my mbp I increase the font size on all pages.
(Reporter)

Comment 7

9 years ago
Marked as duplicate of Bug 479852.  It looks like the issue may span multiple OS's, but at least we can group the scoll issues when zoomed on OSX together.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 479852

Comment 8

9 years ago
Mike: "OSX isn't very
good at specifying a larger default system font size"

If this were a contributor to the problem, then why is there not one trace of it in Safari/WebKit, even with the most difficult pages, e.g.

http://www.mac-tv.de/index.lasso?Rubrik=Filme
You need to log in before you can comment on or make changes to this bug.