If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

proxy configuration dialog has unreadable text box, vertical size is 0 pixels

RESOLVED FIXED

Status

SeaMonkey
Preferences
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Stewart, Assigned: neil@parkwaycc.co.uk)

Tracking

({fixed-seamonkey2.0})

Trunk
x86
Linux
fixed-seamonkey2.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4pre) Gecko/20090321 SeaMonkey/2.0b1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4pre) Gecko/20090321 SeaMonkey/2.0b1pre

In the Advanced.Proxies.Configure dialog, the 4th option, Automatic proxy configuration URL:
is zero pixels high (plus padding), leaving the text invisible.
Also, the Reload button to the right is also narrow vertically, having the same size as the text box including padding.

Reproducible: Always

Steps to Reproduce:
1.Right click on network icon
2.Choose Proxy Configuration
3.Look at 4th option
Actual Results:  
narrow vertical box

I can confirm the text is there by copying the config.pac entry and pasting in the other text boxes.

Expected Results:  
it should be the same height as the other 3 text boxes following the 5th option, Manual proxy configuration

Trunk version seamonkey-2.0b1pre.en-US.linux-i686.tar.bz2
 downloaded 2009-Mar-21
 (Default theme)

Screen capture image at:
http://seahorseCorral.org/images/seamonkey-20b1pre-proxy.png

Updated

9 years ago
Component: General → Preferences
QA Contact: general → prefs
Version: unspecified → Trunk

Comment 1

9 years ago
I can't reproduce this on my Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4pre) Gecko/20090322 NOT Firefox/2.0.0.20 SeaMonkey/2.0b1pre ID:20090322161444 
Fedora Linux 10, KDE 4.2.1.
(Reporter)

Comment 2

9 years ago
No, this never happened in 1.9

I have additional info. This happens when the window is less than 563 pixels wide. Resizing the window does change the behavior of this text box.

Comment 3

9 years ago
I can confirm it on today build in CentOS 5.2 and Gnome.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

8 years ago
Same for me, discovered it today. Seamonkey 2.1a1pre, ID20090918002923 running on Debian Testing. Note that I've set my system to use a Dejavu Sans Mono font everywhere, probably that is the problem but I'm currently unable to test it.

Comment 5

8 years ago
Created attachment 403457 [details]
that is how it actually looks

Dejavu Sans Mono

Updated

8 years ago
Flags: wanted-seamonkey2.0?

Comment 6

8 years ago
I can't reproduce it and so can't decide on wanted or not. If the actual problem can be found, a patch can go through normal channels, but doesn't need the prioritization that wanted might give it.
Flags: wanted-seamonkey2.0?
(Assignee)

Comment 7

8 years ago
Created attachment 403745 [details] [diff] [review]
Proposed patch

I don't think this box needs to be flexible; I think that's what's allowing its height to change. It can't hurt to try this, even though I would have thought that something else would have overflowed in preference.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #403745 - Flags: review?(iann_bugzilla)

Updated

8 years ago
Attachment #403745 - Flags: review?(iann_bugzilla) → review+

Updated

8 years ago
Attachment #403745 - Flags: approval-seamonkey2.0+
(Assignee)

Comment 8

8 years ago
Comment on attachment 403745 [details] [diff] [review]
Proposed patch

Pushed changeset fcc1b20da8be to comm-central.

Can someone who used to be able to reproduce the bug try the next nightly to see if this has fixed it?
(Assignee)

Comment 9

8 years ago
As there's been no reply I'm just going to assume that this is in fact fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: fixed-seamonkey2.0
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.