Closed Bug 484747 Opened 11 years ago Closed 10 years ago

TUnit test_nsIProcess.js leaks 2 nsStringBuffer now

Categories

(Core :: XPCOM, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: sgautherie, Unassigned)

References

Details

(Keywords: memory-leak, regression)

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090318 Minefield/3.6a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/6f21cfb3a12d)

No leak.

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090322 Minefield/3.6a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/8d2c566f3256)

Leaks.

Regression timeframe:
"Should" be one of bug 483626, bug 453185 or bug 421611.
Flags: wanted1.9.2?
Confirmed by
{
http://tinderbox.mozilla.org/showlog.cgi?log=Thunderbird/1238183877.1238186339.30647.gz&fulltext=1
Linux comm-central check on 2009/03/27 12:57:57
}
OS: Windows 2000 → All
Confirmed by
{
http://tinderbox.mozilla.org/showlog.cgi?log=Thunderbird3.0/1238257155.1238260151.7894.gz&fulltext=1
MacOSX 10.4 comm-1.9.1 check on 2009/03/28 09:19:15
}
Flags: wanted1.9.1?
Blocks: 483626, 453185, 421611
Flags: wanted1.9.1? → wanted1.9.1.x?
Really needs an owner if we're going to consider it wanted... If you get a patch, please nominate it for approval.
Flags: wanted1.9.1.x?
I came across this leak working on bug 411511 and thought at first it was my fault :)

It turns out to be caused by set_environment added in bug 421611. See comment at http://mxr.mozilla.org/mozilla-central/source/xpcom/threads/nsEnvironment.cpp#135:

   * Environment strings must have static duration; We're gonna leak all of this
   * at shutdown: this is by design, caused how Unix/Linux implement environment
   * vars.
Thanks for the analysis!

R.WontFix, like bug 203764.
No longer blocks: 453185, 483626
Status: NEW → RESOLVED
Closed: 10 years ago
Depends on: 203764
Flags: wanted1.9.2?
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.