If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

allow autoupdate for installed extension

RESOLVED DUPLICATE of bug 321789

Status

()

Toolkit
Add-ons Manager
--
enhancement
RESOLVED DUPLICATE of bug 321789
9 years ago
9 years ago

People

(Reporter: -fullmetaljacket-, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
currently, firefox will only notify the user if an update is available for his installed extension (firefox will not automatically install it for the user). 

it would be nice if we had a mechanism for automatic update for installed extension on firefox, similar  to firefox's aus mechanism.

Comment 1

9 years ago
Update Notifier ( http://www.longfocus.com/firefox/updatenotifier/ ) handles this very well
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
thank you, i installed that and try it.

that extension will do the trick for now, but it would be great if firefox will had similar built-in functionality.

Comment 3

9 years ago
I don't think this is wise because users trust can be taken avantaged of very easily and unknownigly.

Comment 4

9 years ago
I don't think this is wise because users trust can be taken avantaged of very easily and unknownigly.
(Reporter)

Comment 5

9 years ago
how(In reply to comment #3)

how can it that be? firefox will only updates extensions already installed by the user.

Comment 6

9 years ago
(In reply to comment #5)
> how(In reply to comment #3)
> how can it that be? firefox will only updates extensions already installed by
> the user.

Say whatever the most popular extension is was installed from the extension's home page.  The extenion's author could decide to include spyware/virus and the user would automatically get it without even knowing what could have caused it because the extension automatically updated.
(Reporter)

Updated

9 years ago
Component: General → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 408546
(Reporter)

Comment 8

9 years ago
im duping this 321789.
Duplicate of bug: 321789
You need to log in before you can comment on or make changes to this bug.