Cannot navigate Back past a form that requires resend

RESOLVED DUPLICATE of bug 160144

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 160144
9 years ago
9 years ago

People

(Reporter: L. Mohan Arun, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3

FF 3.1 b3
I have used IE7 and I am now using IE8 also, and this issue did not occur in IE, because IE allows me to go backward past a page that requires form submission to be redone. In FF, I cant navigate past a page that requires form resend.

Reproducible: Always

Steps to Reproduce:
1. Go to ginasprenkle.com
2. Put some test email and test name in the newsletter subscription part.
3. Subscribe
4. Disclaimer - this is not my site, and I dont know gina sprenkle, this is just an example.
5. You will reach the final screen (marketerschoice.com confirmation)
6. Try pressing Back to go back. I dont want the form to be resubmitted, I just want to go back to ginasprenkle.com. There lies the FF form resend problem.
Actual Results:  
Cant navigate, past page that requires form resend.

Expected Results:  
Browser fwd/bwd navigation is an independent function that cannot be related to form submissions. I should be able to choose dont submit the form again, and be able to navigate. If I click on Cancel in FF's dialog about form resubmission, it stays on the same page, and wont navigate as expected. IE handles this issue correctly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 160144
(Reporter)

Comment 2

9 years ago
A quick glance through the other bug marked as duplicate of bug, shows several WONTFIX. I agree that POST DATA cannot be resent for sensitive areas, thats why there should be a Cancel option but that bug does not say about navigation, which is my problem. I have come across this when using Copyscape also, and with Copyscape, it always has to resend the data after going back and forth with the detected duplicates, thus Copyscape counts that as a duplicate check because of another form submission, so thats 5 cents gone for every check. There should be an option to navigate past the resend post data dialog, to a page that is prior to the page, without resending the post data on the current page. So my bug is different in this aspect.
(Reporter)

Comment 3

9 years ago
Hmm I see a downward arrow next to Forward button which should have been next to the back button, that allows the kind of backward navigation I would prefer. It seems to be in the wrong place, because it fills up with previous entries, so it shoul dbe next to the Back button, not Forward button.
You need to log in before you can comment on or make changes to this bug.