Closed Bug 484820 Opened 11 years ago Closed 11 years ago

[FIX]HTML content sink doesn't always notify on kids of <head>

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: bzbarsky, Assigned: bzbarsky)

References

Details

Attachments

(1 file)

Attached patch Proposed fixSplinter Review
In particular, this caused test failures when I fixed bug 481440 because the <title> didn't get notified on.  Sadly, I can't seem to find a way to reproduce this without that patch; if I flush layout before the <title> is parsed and set head and title do display:block the title still shows up in the rendering...
Attachment #368915 - Flags: superreview?(jst)
Attachment #368915 - Flags: review?(bent.mozilla)
Blocks: 481440
Attachment #368915 - Flags: superreview?(jst)
Attachment #368915 - Flags: superreview+
Attachment #368915 - Flags: review?(bent.mozilla)
Attachment #368915 - Flags: review+
Pushed http://hg.mozilla.org/mozilla-central/rev/9799dde18edb
Status: NEW → RESOLVED
Closed: 11 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.