Closed Bug 484860 Opened 12 years ago Closed 3 years ago

Add ISO 8601 YYYY-MM-DD support for dates in preferences

Categories

(Calendar :: Preferences, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: jari.aalto, Unassigned)

Details

User-Agent:       Opera/10.00 (Windows NT 5.1; U; en) Presto/2.2.0
Build Identifier: Thunderbird version 2.0.0.21 (20090302)

The Dates are presented in Windows locale. This is not always preferable and changing the Windows locale is not possible (Non-admin, other applications).

Please add Preferences options to chnage all dates to bre represented in
compact and nicely ordering YYYY-MM-DD format.

Reproducible: Always

Steps to Reproduce:
Feature not yet implemented
Actual Results:  
Feature not yet implemented

Expected Results:  
Feature not yet implemented
Component: Lightning Only → Preferences
QA Contact: lightning → preferences
OS: Windows XP → All
Hardware: x86 → All
Summary: REQUEST: Please add ISO 8601 YYYY-MM-DD support for dates → Add ISO 8601 YYYY-MM-DD support for dates in preferences
This is a great FR!
This bug is still open. The option to change date format is supported by Claws, Evolution etc and yet 10 years on this basic functionality is missing from Thunderbird. The hack to workaround this is also no longer working in 60.0

http://kb.mozillazine.org/Date_display_format

The link between dates formats and LOCAL settings should only at best be a recommendation, and never a forced choice.
The option for indivual datetime formatting is removed from platform and will not come back. Datetime formatting only works based on locale formatting definition anymore.

If you like to file a bug to allow to also to apply a locale of choice for formatting for calendar datetime (e.g. en-DK instead of the the detected app or OS locale), this could be an acceptable enhancement request (though you still rely on the icu definitions).
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
Datetime formatting is no working any more based on locale formatting (en-DK) since upgrading to 60.0
I know it doesn't - therfore I mentioned it's you could file an enhancement request to be able to specify another locale (like en-DK) as a third option appart from using the app or OS locale for datetime formatting. And if you want this to be extended to email and chat, too, you should probably do that (also) for the Thunderbird and not just the Calendar component.
You need to log in before you can comment on or make changes to this bug.