Last Comment Bug 484956 - Use official Sunbird branding and artwork for Ubuntu builds
: Use official Sunbird branding and artwork for Ubuntu builds
Status: RESOLVED INVALID
:
Product: Calendar
Classification: Client Software
Component: Sunbird Only (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 05:18 PDT by John Vivirito
Modified: 2009-03-24 13:00 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description John Vivirito 2009-03-24 05:18:47 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.7) Gecko/2009030516 Ubuntu/9.04 (jaunty) Firefox/3.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.18pre) Gecko/20090112 Ubuntu/9.04 (jaunty) Calendar/0.9

Can we please use the bird icon as default icon, its nicer than the calendar icon.
We have recieved requests from this, It is fixable on Ubuntus end however, it would be great if mozilla would use it as default. Link i have is:
http://markcarson.com/MarkCarson/images/sunbird/Sunbird-256x256-white.png


Reproducible: Always

Steps to Reproduce:
1.N/A
2.
3.
Actual Results:  
Uses the while calender by default see link below:
http://markcarson.com/images/sunbird/Calendar-Logo-256x256.png

Expected Results:  
To use the bird icon

Ubuntu bug report is 
https://bugs.launchpad.net/ubuntu/+source/lightning-sunbird/+bug/178785
Comment 1 Stefan Sitter 2009-03-24 05:58:23 PDT
Only the official release builds use the Sunbird branding and artwork that is trademarked by the Mozilla Foundation. Nightly builds and unofficial builds use the generic Calendar branding and artwork. Firefox and Thunderbird do the same.

Enabling official branding for Ubuntu builds requires just one additional line in the build configuration (|ac_add_options --enable-official-branding|). 

But I don't know if Ubuntu is allowed to use it. You might checkout <http://www.mozilla.org/foundation/trademarks/> or contact the Mozilla Foundation. You could check too what Ubuntu did regarding Firefox/Thunderbird that has the same issue.
Comment 2 John Vivirito 2009-03-24 08:13:27 PDT
we use oficial branding for all other final releases we have also made an abrowser package with unofficial branding.
Thunderbird Firefox and seamonkey we use official branding, Debian however doesnt use the official brandin gon all Mozilla products AFAIK
Comment 3 Simon Paquet [:sipaq] 2009-03-24 11:17:49 PDT
This is not a bug on our side --> INVALID

As Stefan said in comment 1, please discuss this (whether you can use official branding for Sunbird in Ubuntu) with the Mozilla Foundation (Gervase Markham (gerv AT mozilla DOT org) might be a good contact person). Please keep either me or our lead developer, Philipp Kewisch (mozilla AT kewis DOT ch) in the loop.
Comment 4 John Vivirito 2009-03-24 12:54:57 PDT
Thanks i will email him and ask him.
I will. Thanks
Comment 5 Alexander Sack 2009-03-24 13:00:50 PDT
I don't know what this issue is about, but it is a non issue from ubuntu side. No action required on mozilla side.

John, you don't need to mail anyone ;). Thanks!

Note You need to log in before you can comment on or make changes to this bug.