Fullscreen video crashed firefox [@ libc-2.9.so@0x2ce27 ]

RESOLVED DUPLICATE of bug 469439

Status

()

--
critical
RESOLVED DUPLICATE of bug 469439
10 years ago
7 years ago

People

(Reporter: jiaji.wang, Unassigned)

Tracking

({crash})

1.9.1 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3

The flash video player on youku.com will make the browser crash if you switch to full screen mode

Reproducible: Always

Steps to Reproduce:
1. Go to youku.com
2. Open any video
3. Switch to full screen mode
Actual Results:  
Browser crashed.

Expected Results:  
Play full screen video
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090321 Shiretoko/3.5b4pre

No crash here. Please read: https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report

Comment 2

10 years ago
What version of flash are you using?

Updated

10 years ago
Component: Extension Compatibility → Plug-ins
Product: Firefox → Core
QA Contact: extension.compatibility → plugins

Updated

10 years ago
Keywords: crash
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> What version of flash are you using?

The latest version, the actual number is too long for me to remember, but I updated my Ubuntu to the latest.

Comment 4

9 years ago
Confirmed on Fedora 10 with FF 3.1b3 and flash plugin 10.0.22.87 

Build identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3

Crash report: 
http://crash-stats.mozilla.com/report/index/682ef5ea-428f-452b-a350-92de12090422

Comment 5

9 years ago
This bug is not limited to youku.com btw, I get the same result with all flash based video content (youtube etc. etc.)
This is in safe mode or a new profile?
Summary: Fullscreen video crashed firefox → Fullscreen video crashed firefox [@ libc-2.9.so@0x2ce27 ]
Version: unspecified → 1.9.1 Branch

Comment 7

9 years ago
This was in safe mode. I've also just reproduced the crash with a random youtube video and safe mode + a new untouched profile:

http://crash-stats.mozilla.com/report/index/3bd93b78-dd73-467b-b9cf-334a32090423

The crash does not occur if hardware acceleration is disabled in the flash plugin.

Backtrace points to libGL.so which in my case is provided by NVidia (version 180.29). I would have attributed this to a NVidia and/or Adobe flash bug, but everything works perfectly in Konqueror (exact same flash plugin used) both with and without hardware acceleration enabled.

======= Backtrace: =========
/lib/libc.so.6[0x88c3a4]
/lib/libc.so.6(cfree+0x96)[0x88e356]
/usr/lib/nvidia/libGL.so.1[0x373a365]

Comment 8

9 years ago
well, i'm glad you'd attribute it to nvidia, because that's all we can do. file a bug w/ them and provide urls to cross link these bugs.

just because one browser doesn't crash doesn't mean it's the fault of the browser. the stack clearly faults nvidia, as they don't provide symbols we're unable to do anything. it's nvidia's job to either provide symbols or work w/ the caller to debug the problem. most likely the caller is adobe and they can either work w/ them directly, or through our bug system. however we can't do anything. and they can't until you report this bug to them.

Comment 9

9 years ago
I've tried poking nVidia about this at http://www.nvnews.net/vbulletin/showthread.php?p=1997651

There is a workaround which is to create a script that does the following.
#!/bin/sh
export LD_PRELOAD=/usr/lib/libGL.so.1
/path/to/firefox

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Updated

9 years ago
Duplicate of this bug: 473010

Updated

9 years ago
Duplicate of this bug: 492348

Updated

9 years ago
Resolution: INVALID → DUPLICATE
Duplicate of bug: 469439
(Assignee)

Updated

7 years ago
Crash Signature: [@ libc-2.9.so@0x2ce27 ]
You need to log in before you can comment on or make changes to this bug.