Private Data Settings button in Privacy Tab is Usable in PB mode

RESOLVED DUPLICATE of bug 471898

Status

()

defect
RESOLVED DUPLICATE of bug 471898
10 years ago
10 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

3.5 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

10 years ago
litmus test case: 7545
Build Id: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3 ID:20090305134136

When a user enables Private Browsing mode, the Private Data Settings button in the Privacy pane (within the Preferences dialog box) is usable. Meanwhile, the "Clear Recent History" option under the Tools menu is grayed-out. This behavior only occurs in the 1.9.1 branch as the latest Minefield build doesn't seem to have this issue.

Steps to Reproduce:
1. Enter Private Browsing Mode
2. Go to the Preferences/Options Dialog box
3. Click on the Privacy Tab and click on the "Settings" button under the Private Data section.

Actual Results:
The Settings button is usable.

Expected Results:
The Settings button should be grayed-out.
Reporter

Comment 1

10 years ago
Ack, there is a bug already created for this issue: https://bugzilla.mozilla.org/show_bug.cgi?id=471898

I'm going to file this as resolved duplicated.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 471898

Comment 2

10 years ago
Is it really a dupe of that bug?  That bug was about the fact that the Setting button was enabled if the pref next to it was disabled...
Reporter

Comment 3

10 years ago
Yep, that's the behavior I was pointing toward. In my steps to reproduce, the pref isn't put in there to leave it generalized. With that fix, it should fix the inherent issue of this bug.
You need to log in before you can comment on or make changes to this bug.