Crashes at shutdown and after installing a new add on. [@ CallQueryInterface<nsISupports, nsXPCOMCycleCollectionParticipant>(nsISupports*, nsXPCOMCycleCollectionParticipant**) ]

REOPENED
Unassigned

Status

()

Firefox
General
--
critical
REOPENED
9 years ago
2 years ago

People

(Reporter: gaby2300, Unassigned)

Tracking

({crash})

3.5 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-AR; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-AR; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3

It always crashes when I shut it or when I restart it after installing a new add on (the crash report window appears)

Reproducible: Always

Steps to Reproduce:
Option 1:
1. Start up Firefox.
2. Shut down Firefox.
3. The crash report window appears.

Option 2
1. Start up Firefox.
2. Install a new add on.
3. Restart Firefox.
4. The crash report window appears.
Actual Results:  
Option 1 and 2: It crashed.

Expected Results:  
Option 1: Shut down with out crashing. The crash report window should not have appeared.
Option 2: Restart with out crashing. The crash report window should not have appeared.

Theme: Little Fox 1.8.48

Talkback crash ID 	Fecha de envío
42de665a-8bc7-4336-8ba9-ab4c12090324	24/03/2009	06:39 p.m.
e9cacc4a-6d3c-47b2-9bfc-dc0972090324	24/03/2009	06:36 p.m.
e47fae5b-987b-493c-8cf5-7985d2090324	24/03/2009	06:35 p.m.
3efd4ae8-6c12-474b-bfc7-41f7b2090323	24/03/2009	02:05 a.m.
98d7c41e-7a06-4419-9a18-ea73a2090323	24/03/2009	01:29 a.m.
f6071592-e4c5-4aea-b3e9-0bbff2090322	22/03/2009	11:32 p.m.
ddf95542-0139-42bf-b8ff-636ed2090322	22/03/2009	09:43 p.m.
54675c88-02a6-49a4-ba7d-d62532090322	22/03/2009	07:19 p.m.
(Reporter)

Updated

9 years ago
Alias: Gaby2300
Keywords: crash
Version: unspecified → 3.1 Branch
Do you crash after installing random addons or after installing a special one ?

0  	xul.dll  	CallQueryInterface<nsISupports,nsXPCOMCycleCollectionParticipant>  	obj-firefox/dist/include/xpcom/nsISupportsUtils.h:203
1 	xul.dll 	nsXPConnect::Traverse 	js/src/xpconnect/src/nsXPConnect.cpp:749
2 	xul.dll 	nsTHashtable<nsDomainEntry>::s_HashKey 	
3 		@0x3332fff
Hardware: Other → x86
Summary: Crashes at shutdown and after installing a new add on. → Crashes at shutdown and after installing a new add on. [@ CallQueryInterface<nsISupports, nsXPCOMCycleCollectionParticipant>(nsISupports*, nsXPCOMCycleCollectionParticipant**) ]
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> Do you crash after installing random addons or after installing a special one ?
> 
> 0      xul.dll     
> CallQueryInterface<nsISupports,nsXPCOMCycleCollectionParticipant>     
> obj-firefox/dist/include/xpcom/nsISupportsUtils.h:203
> 1     xul.dll     nsXPConnect::Traverse    
> js/src/xpconnect/src/nsXPConnect.cpp:749
> 2     xul.dll     nsTHashtable<nsDomainEntry>::s_HashKey     
> 3         @0x3332fff

I haven't tried to uninstall the extensions but I will.

Please remember that it crashes every time I shut down, and not only when I restart after having installed an extension.
(Reporter)

Comment 3

9 years ago
I've uninstalled the extensions. It still crashes every time I shut it down. This never happened with the nightly builds (Minefield), nor with Shiretoko.

Comment 4

9 years ago
Looks like this might be #19 on the fx3.5b4 topcrash list

Here are some additional user comments

PL_DHashTableOperate    0x0     200905121345    18      3693953
        
        Not sure - crash was on launch. 
        http://crash-stats.mozilla.com/report/index/235e358e-e9de-4e4f-a024-ae7912090512

PL_DHashTableOperate    0x0     200905091603    8       \N
        
        لقد انهارد فاير فوكس هل يمكنك ان تصحلة مرة اخرى 
        http://crash-stats.mozilla.com/report/index/6a187325-4de9-4d91-b184-5ebf52090509

PL_DHashTableOperate    0x0     200905131704    8       3220117
        
        downloading veoh
        http://crash-stats.mozilla.com/report/index/8ec2921d-d4a5-4399-87ca-488a12090513

PL_DHashTableOperate    0x0     200905090715    1       \N
        
        jhbzhvbxhb x\r\nvbhbx x\r\nxhbxh x \r\nfhxb xc \r\n
        http://crash-stats.mozilla.com/report/index/9fc9b864-70ab-4d94-888b-5a6342090509

PL_DHashTableOperate    0x0     200905090056    25      \N
        
         Clicked on link in an email message (abc news) just before getting crash message.
        http://crash-stats.mozilla.com/report/index/b650ffb9-7728-4b22-bf5f-ef6d92090509

PL_DHashTableOperate    0x0     200905072209    2       25466288
        
        installed roboform, which said it wanted to close all windows
        http://crash-stats.mozilla.com/report/index/bd0efc4b-f1b2-44b6-8906-33c3d2090507

PL_DHashTableOperate    0x184b1b8       200905071650    163817  2599207
        about:blank
        English text was comming up as square boxes before the crash. 
        http://crash-stats.mozilla.com/report/index/7ff2206f-c463-404e-ba05-119392090507

PL_DHashTableOperate    0x8     200905080107    137     72963
        
        This final beta is a lot more unstable than many of the nightly builds - I recommend switching to one of them to anyone who doesn't mind living on the edge;-)
        http://crash-stats.mozilla.com/report/index/908fa3c5-acc8-4604-b29b-84a172090508

Comment 5

9 years ago
Gabriela, are you still hitting these crashes on shutdown, using Firefox 3.5 or trunk?  If you're not, please mark the bug as worksforme.  If you are, let's try to figure out why.

Many crashes that mysteriously only happen for some users involve files in the Firefox profile.  If you use a fresh one, does the crash go away?  Can you figure out which file from your main profile triggers the crash, e.g. by copying files into the new profile one at a time?

Updated

9 years ago
Whiteboard: [needs info from reporter]
(Reporter)

Comment 6

9 years ago
Jesse, no I'm very very seldom crashing with Firefox 3.5 and 3.5.1.
How do I mark the bug as worksforme?

Comment 7

9 years ago
Good to hear :)

To mark a bug as worksforme, you have to select "resolved" from the "status" dropdown, and then another dropdown for resolution appears.  It's not at all obvious :(
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

9 years ago
Many thanks for your interest in my issue. Luckily the crashes don't occur any more with FF 3.5 and 3.5.1
It's not at all obvious!!! 
I looked below this field in my previous message but I could only see the Resolved/Unconfirmed option. 
I'll just mark the bug as you say and many thanks again!

Updated

9 years ago
Whiteboard: [needs info from reporter]
Reopening since I hit this bug on the trunk. Like Gabriela I had a pending addon install that may have caused it. Crash stats show only 1 other crash besides mine on the trunk recently. http://crash-stats.mozilla.com/report/index/bp-d282ad88-6294-4dcd-8150-e1cca2091216 is my report. 

Here were my STR:
1. With Minefield running, have an addon in the install queue (I think it was Chatzilla)
2. Left the machine. Came back and after I did the first thing in a browser window I got the crash.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
I got this crash again today shortly after updating to the 20091228 build. This time I did not install an addon. Immediately after it I got the crash in Bug 536224.

Updated

8 years ago
Alias: Gaby2300

Comment 11

8 years ago
http://crash-stats.mozilla.com/report/pending/7c8921ad-baf5-497f-a23c-189062100713

Add-ons: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}:1.3a.20100704,compatibility@addons.mozilla.org:0.5,{46551EC9-40F0-4e47-8E18-8E5CF550CFB8}:1.0.11,{972ce4c6-7e08-4474-a285-3208198ce6fd}:4.0b2pre
BuildID: 20100713040624
CrashTime: 1279029802
EMCheckCompatibility: false
FramePoisonBase: 00000000f0de0000
FramePoisonSize: 65536
InstallTime: 1279029287
ProductName: Firefox
ReleaseChannel: nightly
StartupTime: 1279029289
Theme: classic/1.0
Throttleable: 1
URL: http://www.html5test.com/
Vendor: Mozilla
Version: 4.0b2pre
Status: NEW → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 578215
This bug was filed before the crashing code was even written. No dupe.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
I'd assume |wrapper->Native()| returned null at <http://mxr.mozilla.org/mozilla-central/source/js/src/xpconnect/src/nsXPConnect.cpp#693>, though that should never happen.
(Assignee)

Updated

7 years ago
Crash Signature: [@ CallQueryInterface<nsISupports, nsXPCOMCycleCollectionParticipant>(nsISupports*, nsXPCOMCycleCollectionParticipant**) ]

Updated

2 years ago
Crash Signature: [@ CallQueryInterface<nsISupports, nsXPCOMCycleCollectionParticipant>(nsISupports*, nsXPCOMCycleCollectionParticipant**) ] → [@ CallQueryInterface<nsISupports, nsXPCOMCycleCollectionParticipant>(nsISupports*, nsXPCOMCycleCollectionParticipant**) ] [@ CallQueryInterface<T> ]
You need to log in before you can comment on or make changes to this bug.