Closed Bug 485177 Opened 11 years ago Closed 11 years ago

Chatzilla (0.9.84) shows the same name for all users with latest FF builds

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: smaug, Unassigned)

References

Details

(Keywords: fixed1.9.1, regression, testcase)

Attachments

(2 files)

I guess this is a regression from some core change.
CZ+FF20090319 works fine.

Screenshot coming...
Attached image screenshot
(In reply to comment #0)
> I guess this is a regression from some core change.
> CZ+FF20090319 works fine.
> 
> Screenshot coming...

Which one didn't work? You didn't give a build ID for what you used to take that screenie. :-)
Trunk 20090324 doesn't work.
OK. If you right click them, does the right name show up in the context menu?
(In reply to comment #4)
>If you right click them, does the right name show up in the context menu?
Yes.

As I said, I think this is a regression from some core change.
May the latest tracemonkey merge?

I filed this to Chatzilla, because I don't know where else to start.
(In reply to comment #5)
> (In reply to comment #4)
> >If you right click them, does the right name show up in the context menu?
> Yes.
> 
> As I said, I think this is a regression from some core change.
> May the latest tracemonkey merge?
> 
> I filed this to Chatzilla, because I don't know where else to start.

Sure, that's fine. I was just checking if the back-end parts were broken (eg. tracemonkey/spidermonkey/dom things being bad) or the display. A quick look at hgpushlog and searching for "tree" or "list" only gives me bug 162063, which seems only half-likely. I guess we could do with a better regression range... I'll try to get us one.
(In reply to comment #3)
> Trunk 20090324 doesn't work.

I can't reproduce this: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.2a1pre) Gecko/20090324 Minefield/3.6a1pre

Stock trunk nightly build off the FTP, datestamp 24/03/2009 11:11:00 AM

What exactly are you running and/or doing in order to repro this?
note, it is my own 20090324 build, so might not be exactly the same as
what ftp.m.o has. This on has the latest Tracemonkey merge (Tue Mar 24 10:50:03 2009 -0700).

Otherwise, I do nothing special. Open FF, open CZ and it automatically
opens few channels. None of the channels shows the names correctly.
Just setting a channel to open at startup doesn't allow me to reproduce this either. Can you reproduce this running the same profile on a stock trunk build?
This happens only if chrome.jit = true.r
Assignee: rginda → general
Component: ChatZilla → JavaScript Engine
Keywords: regression
Product: Other Applications → Core
QA Contact: chatzilla → general
Er, true.

This seems to be a regression from the TM merge yesterday, at least I think so.
Severity: normal → major
Attached file reduced shell testcase
This passes on 1.9.0 and current m-c tip:
./js -f test_485177.js

but fails with the JIT on current m-c tip:
./js -j -f test_485177.js
Flags: blocking1.9.1?
Keywords: testcase
Flags: blocking1.9.1? → blocking1.9.1+
Also fails on current tracemonkey tip, fwiw.
fixed by upvar
Depends on: upvar2
should be fixed by bug 483179
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Keywords: fixed1.9.1
You need to log in before you can comment on or make changes to this bug.