Temporary files for external viewer are put in Desktop regardless of cache and Download folder setup.

RESOLVED DUPLICATE of bug 476174

Status

RESOLVED DUPLICATE of bug 476174
10 years ago
10 years ago

People

(Reporter: arifsaha, Unassigned)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b4pre) Gecko/20090322 SeaMonkey/2.0b1pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b4pre) Gecko/20090322 SeaMonkey/2.0b1pre

When I open files (clicked a link or go the URL directly) that need to be viewed by external viewers (e.g. PDF files), SeaMonkey download the files into Desktop ($HOME/Desktop), regardless the fact that there is no setup to point SeaMonkey to the ~/Desktop; both cache folder location and default Download folder point to another folder / directory.


Reproducible: Always

Steps to Reproduce:
1. Make sure cache folder location and default Download folder does not point to ~/Desktop
2. Open a file need to be viewed by external viewer (such as PDF files), either by clicked a link or enter the URL directly. The provided mozilla.org page will have a lot of PDF to try.

Actual Results:  
A temporary file will show up in Desktop during downloading, eventually renamed to the original name of the files (if possible), still in Desktop, just before the external viewer fired up. The file will stay in Desktop during and after the viewing.

Expected Results:  
The temporary file and the end downloaded file should be downloaded under the cache folder / directory location, like in version 1.1.x; therefore it is obvious it is temporary files that can be removed anytime.
dupe or related to bug 311292, bug 454242, bug 476174
Version: unspecified → Trunk

Comment 2

10 years ago
Duping to Bug 476174 for the time being.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 476174

Comment 3

10 years ago
This bug is related to bug 311292
You need to log in before you can comment on or make changes to this bug.