OS X font Monaco-9 display unclear

RESOLVED DUPLICATE of bug 345392

Status

()

--
minor
RESOLVED DUPLICATE of bug 345392
10 years ago
10 years ago

People

(Reporter: kwiniec, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.7) Gecko/2009021906 Firefox/3.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.7) Gecko/2009021906 Firefox/3.0.7

See attachments.  3.0.x displays the 9-point Monaco font on OS X unclearly, unlike 2.0.0.x and Safari.  "Monaco-9" has been the small monospace font of choice on the Macintosh for decades due to its unique clarity and programmer-friendliness.

Reproducible: Always
(Reporter)

Comment 1

10 years ago
Created attachment 369330 [details]
displays of font Monaco-9 on OS X

Each sample is shown with the HTML tag that generated it and the sizes that the resulting displays would actually be equivalent to for FF2 /Safari / FF3.
(Reporter)

Comment 2

10 years ago
Created attachment 369332 [details]
HTML used to generate displays of font Monaco-9 on OS X

Generates Monaco-9 font display samples for various HTML tags and remarks on the equivalent sizes of the resulting displays for FF2 / Safari / FF3.

Updated

10 years ago
Component: General → Layout: Text
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text

Updated

10 years ago
Component: Layout: Text → GFX: Thebes
Depends on: 389074
QA Contact: layout.fonts-and-text → thebes
I don't see how this depends on bug 389074. That relates to the "shaping" process - character to glyph mapping, ligatures, kerning, etc - but the eventual drawing of the glyph runs is the same whether we use the Core Text or ATSUI paths to generate them.
This is essentially a dupe of bug 345392; by default Gecko is AAing all fonts of all sizes, whereas Mac OS X sets the AA threshold and then exempts certain fonts (including, but perhaps not limited to, Monaco and those with Courier in their name) below 10px.  

Or, see bug 345392 comment 10 for a more comprehensive explanation (which also explains how you can still have fuzzy Monaco 9 even when you set the hidden Gecko pref to respect the OS AA threshold).

Unless Jonathan's implementation of CoreText for Thebes implements this fancy logic, I can't see how this bug depends on bug 389074, either.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 345392
You need to log in before you can comment on or make changes to this bug.