Closed Bug 485264 Opened 11 years ago Closed 11 years ago

Error message "dirname: extra operand `Files/Microsoft'" when running configure

Categories

(Firefox Build System :: General, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: wtc, Assigned: benjamin)

Details

Attachments

(2 files, 1 obsolete file)

I use MozillaBuild 1.3 on Windows XP SP2, with Visual C++ 2005
Professional Edition SP1.

When I do "make -f client.mk build", the configure script emits
the following error messages:

  checking for ml... /c/Program Files/Microsoft Visual Studio 8/VC/BIN/ml
  dirname: extra operand `Files/Microsoft'
  Try `dirname --help' for more information.
  basename: extra operand `Visual'
  Try `basename --help' for more information.

The error messages from dirname are clearly caused by the spaces in
the pathname of ml.  In spite of these error messages, the build
is proceeding without problems.
Assignee: nobody → benjamin
Attachment #369505 - Flags: review?(ted.mielczarek)
Attachment #369505 - Flags: review?(ted.mielczarek) → review+
http://hg.mozilla.org/mozilla-central/rev/c98003848229
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Ben, thanks for the fix.  While verifying your bug fix,
I found that the original error messages from 'dirname'
and 'basename' are gone, but there is a new error message
from 'cd':

checking for ml... /c/Program Files/Microsoft Visual Studio 8/VC/BIN/ml
/c/firefox-tip/src/configure: cd: /c/Program: No such file or directory
Attached patch patch for Comment #3 (obsolete) — Splinter Review
Attachment #370790 - Flags: review?(benjamin)
Attachment #370790 - Attachment is obsolete: true
Attachment #370872 - Flags: review?(benjamin)
Attachment #370790 - Flags: review?(benjamin)
Attachment #370872 - Flags: review?(benjamin) → review+
Thanks.  This is the configure output now:

checking for ml... /c/Program Files/Microsoft Visual Studio 8/VC/BIN/ml
Status: RESOLVED → VERIFIED
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.