Closed Bug 485300 Opened 11 years ago Closed 11 years ago

[newsearch] "Did you mean?" suggests the same search terms

Categories

(support.mozilla.org :: General, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: stephend, Assigned: paulc)

References

()

Details

(Whiteboard: sumo_only)

Attachments

(1 file, 2 obsolete files)

Steps to Reproduce:

1. Load http://support-stage.mozilla.org/tiki-newsearch.php?locale=ja&q=%E8%B3%AA%E5%95%8F&where=d&l=ja&filter_lang=1&author=&filter_author=0&en_too=1&type=0&answered=0&lastmodif=0
2. Click on the "Did you mean '質問'?" link: (http://support-stage.mozilla.org/tiki-newsearch.php?locale=ja&q=%E8%B3%AA%E5%95%8F&where=d&l=ja&filter_lang=1&author=&filter_author=0&en_too=1&type=0&answered=0&lastmodif=0)

Expected Results:

After clicking that link once, the correct characters/phrase should be found and the user should be redirected to that term's page

Actual Results:

It keeps suggesting the same string
I'll take a look tomorrow morn ;)
Assignee: nobody → paul.craciunoiu
Target Milestone: --- → 1.0
Target Milestone: 1.0 → 1.1
Target Milestone: 1.1 → 1.0.2
Depends on: 405028
This is needed for 1.0.2
Priority: -- → P2
I don't get this specific URL locally (maybe it's the reindexing?)
http://support-stage.mozilla.org/tiki-newsearch.php?locale=ja&q=%E8%B3%AA%E5%95%8F&where=d&l=ja&filter_lang=1&author=&filter_author=0&en_too=1&type=0&answered=0&lastmodif=0
In other words, there's no "Did you mean?" for me.

I'd need a new case to reproduce this. I'm playing around locally but I don't get any yet.
FWIW, I don't experience this locally, either. I suggest we wait until bug 488374 is resolved since that's the big piece missing between the local and staging instances.
Agree with you, Eric.
Depends on: 488374
https://support-stage.mozilla.org/tiki-newsearch.php?locale=en&q=VG+safe&where=d&l=en&filter_lang=1&author=&filter_author=0&en_too=1&type=0&answered=0&lastmodif=0, which is a search for "VG Safe", keeps suggesting the same search over and over, without ever messaging the user that no search result exists for that phrase
(In reply to comment #6)
> https://support-stage.mozilla.org/tiki-newsearch.php?locale=en&q=VG+safe&where=d&l=en&filter_lang=1&author=&filter_author=0&en_too=1&type=0&answered=0&lastmodif=0,
> which is a search for "VG Safe", keeps suggesting the same search over and
> over, without ever messaging the user that no search result exists for that
> phrase

Correction; sorry, I mean that it does, below, "No pages matched the search criteria", but then suggests the same term, as already noted above (it's not very noticeable, in comparison to the "Did you mean..." text.
So, there are a few problems at play here. 

Firstly, there seems to be a problem with query encoding. A search for 'この' in the ja locale should give you a ton of articles, but only gives articles for the English translation. Using mb_convert_encoding with 'UTF-8' and 'auto' can fix this.

Secondly, "Did you mean" doesn't work with languages that don't use a 'space' as a delimiter for words. Not so sure about a fix for this. I need to look at the 'Did you mean' code still.
(In reply to comment #6)
> https://support-stage.mozilla.org/tiki-newsearch.php?locale=en&q=VG+safe&where=d&l=en&filter_lang=1&author=&filter_author=0&en_too=1&type=0&answered=0&lastmodif=0,
> which is a search for "VG Safe", keeps suggesting the same search over and
> over, without ever messaging the user that no search result exists for that
> phrase
First, I see it on staging, but still doesn't happen locally. Eric, do you want to proceed with the mb_convert_encoding fixes? I can help out.

Secondly, "Did you mean" will probably be better to implement using an open source spell checker, or something of the sort. A few examples are in this thread:
http://www.sphinxsearch.com/forum/view.html?id=526
OR, even better, Media Wiki already implemented this from SphinxSearch, and we could try to use their code:
http://www.mediawiki.org/wiki/Extension:SphinxSearch#Did_You_Mean

Laura, what do you think?
Summary: Search for Japanese characters in new search keeps suggesting the same characters/term → newsearch: "Did you mean?" suggests the same search terms
I filed bug 489277 to handle the encoding issues.
Severity: major → normal
Priority: P2 → --
Target Milestone: 1.0.2 → Future
Summary: newsearch: "Did you mean?" suggests the same search terms → [newsearch] "Did you mean?" suggests the same search terms
Attached patch patch, v1 (obsolete) — Splinter Review
This is a very simple patch that should take care of it.
Attachment #386638 - Flags: review?(smirkingsisyphus)
Attachment #386638 - Flags: review?(laura)
Target Milestone: Future → 1.3
Attached patch patch, v2 (obsolete) — Splinter Review
Oops, of course I meant "!=" not "==" :(
Attachment #386638 - Attachment is obsolete: true
Attachment #387483 - Flags: review?(smirkingsisyphus)
Attachment #387483 - Flags: review?(laura)
Attachment #386638 - Flags: review?(smirkingsisyphus)
Attachment #386638 - Flags: review?(laura)
Attached patch patch, v2Splinter Review
I need to watch my attaching skills.
Attachment #387483 - Attachment is obsolete: true
Attachment #387484 - Flags: review?(smirkingsisyphus)
Attachment #387484 - Flags: review?(laura)
Attachment #387483 - Flags: review?(smirkingsisyphus)
Attachment #387483 - Flags: review?(laura)
Attachment #387484 - Flags: review?(smirkingsisyphus)
Attachment #387484 - Flags: review?(laura)
Attachment #387484 - Flags: review+
Target Milestone: 1.3 → 1.4
Can just this one go in with 1.3?  It's frustrating/confusing to users.
Target Milestone: 1.4 → 1.3
r48549 / r48550
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Whiteboard: sumo_only
You need to log in before you can comment on or make changes to this bug.