Lightning generates invalid common name (CN) parameter value and/or invalid ATTENDEE property value

RESOLVED WORKSFORME

Status

Calendar
Lightning Only
RESOLVED WORKSFORME
9 years ago
6 years ago

People

(Reporter: Bernard Desruisseaux, Unassigned)

Tracking

Lightning 0.9
x86
Windows XP

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20 X-ORACLE-DEBUG=STATS
Build Identifier: Lightning 0.9

There is an issue with the "Address Autocompletion" feature of Thunderbird/Lighting that causes Lightning to generate iCalendar objects with invalid CN parameter values and/or invalid ATTENDEE property values.

When one adds an attendee in the "Invite Attende" dialog box (e.g., "barb") Lightning looks for matching entries in the local address books as well as in the configured directory server. When a matching entry is found, the text that was entered (e.g., "barb") is automatically changed to:

  barb >> "Jensen, Barbara" <barbara.jensen@example.com>

Most of the time Lightning will "cleanup" the attendee info to:

 "Jensen, Barbara" <barbara.jensen@example.com>

but will sometime leave it as is with the "barb >>" prefix which will causes some problems:

a) The CN parameter of the corresponding ATTENDEE property is invalid:

ATTENDEE;RSVP=TRUE;CN="barb >> "Jensen, Barbara"";PARTSTAT=NEEDS-
 ACTION;ROLE=REQ-PARTICIPANT:mailto:barbara.jensen@example.com

b) The Recipient request header of a CalDAV free busy request may be invalid:
I once saw this request header specified as:
  Recipient: mailto:"abcdefghijklmnopqrstuvwxyz\" <abc@example.com>\""
instead of:
  Recipient: mailto:abc@example.com

Reproducible: Always

Steps to Reproduce:
1. Create new card in Personal AddressBook with:
   Display: abcdefghijklmnopqrstuvwxyz,abcdefghijklmnopqrstuvwxyz
   Email: abc@example.com
2. Create new event, click on Invite Attendee, enter "abc" followed by <Enter> as the attendee name/address
3. If address autocompletion is enabled and you are unlucky, the attendee will end up being displayed as:

abc >> "abcdefghijklmnopqrstuvwxyz,abcdefghijklmnopqrstuvwxyz" <abc@example.com>

4. Close the Invite Attendees dialog box by clicking on the Ok button.

Note that clicking once on the attendee address/name will cause Ligthning to properly cleanup the attendee name/address by removing the "abc >>" prefix.
Actual Results:  
Event creation/modification will be rejected by CalDAV server (400 Bad Request) since the iCalendar object submitted was syntactically invalid.

Expected Results:  
Lightning should automatically remove the text entered by the end user along with the ">>" that are added.
(Reporter)

Comment 1

9 years ago
Created attachment 369537 [details]
Invite Attendee dialog box with the described issue

Updated

9 years ago
Component: General → Lightning Only
Version: unspecified → Lightning 0.9
(Reporter)

Comment 2

9 years ago
Correction:

=> Reproducible: Not Always

Comment 3

9 years ago
I *think* Lightning just reuses the address autocomplete functionality from Thunderbird. Could you test if Thunderbird exposes the same issue, e.g. in the compose window when writing an email message? 

Does the issue still exists testing Thunderbird 3 Beta 2 or newer and a recent Lightning 1.0pre nightly test build?
(Reporter)

Comment 4

9 years ago
(In reply to comment #3)
> I *think* Lightning just reuses the address autocomplete functionality from
> Thunderbird.

That's what I think as well.

> Could you test if Thunderbird exposes the same issue, e.g. in the
> compose window when writing an email message?

I've seen this behavior in the Compose window of Thunderbird, but it seems harder to reproduce the issue. That being said, running the following command in my message storage: 

% find . -type f -exec egrep -i '^(From:|To:|CC:|Bcc:).*>>' {} /dev/null \;

revealed a lot of messages with this issue.  For instance:

To: "bernard.des >> \"Desruisseaux,Bernard\"" <bernard.desruisseaux@oracle.com>
 
> Does the issue still exists testing Thunderbird 3 Beta 2 or newer and a recent
> Lightning 1.0pre nightly test build?

I'm currently not setup to test this myself.  Perhaps someone else can do it, else I'll get back to you later...
(Reporter)

Comment 5

9 years ago
Note that while Thunderbird escapes the double quotes with a backslash in email headers, there is actually no escaping defined in iCalendar to allow a double quote to be specified in a parameter value.  See:

http://lists.osafoundation.org/pipermail/ietf-calsify/2008-December/002129.html

Comment 6

6 years ago
Bernard, does the problem still exists using Thunderbird 7 with Lightning 1.0b7?
(Reporter)

Comment 7

6 years ago
I was unable to reproduce with Thunderbird 10.0.2 and Lightning 1.2.1.  Thanks!
Resolving as WORKSFORME per comment#7
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.