Closed Bug 485465 Opened 11 years ago Closed 11 years ago

wince fennec ignores "command line" options

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Windows CE
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: aki, Unassigned)

References

Details

I've attempted various switches... /help, /h, /p, --profile, /profile, url, etc.  It doesn't appear as if wince fennec actually pays attention to these.

This is currently blocking automated testing for me, since all I'm able to do is launch fennec, which waits at the first launch gif and does nothing without human intervention.

If adding cmdln options isn't a plausible solution, perhaps I can create a file in the fennec directory that gives the same info?  The switches would be preferred, of course.
Flags: wanted-fennec1.0?
Oh, also, when loading the getInfo.html page in fennec, it warns about possible tomfoolery and asks if I want it to remember my decision.  I click "remember my decision" and "yes" and it runs quit.js.  The next time it asks again.  Either it didn't remember or this is a problem with the missing /profile option.
This is most likely happening because we are not passing any cmdline args to xulrunner when we spawn it from the xulrunner-stub. We only do that on WinCE.
This issue seems to be fixed the patch for Bug 487174.

I confirmed that "fennec.exe http://www.google.com/" loads Google correctly.
(In reply to comment #3)
> This issue seems to be fixed the patch for Bug 487174.

Yes it would be fixed by that bug
Depends on: 487174
I can also verify that "fennec.exe -jsconsole" works too
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Flags: wanted-fennec1.0?
You need to log in before you can comment on or make changes to this bug.