Closed Bug 485505 Opened 11 years ago Closed 10 years ago

nl's start page should be localized

Categories

(www.mozilla.org :: General, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: samuel.sidler+old, Unassigned)

Details

Not sure where the problem is, but in testing 3.0.8 builds I noticed that nl's start page isn't localized (at least on Windows XP).

http://www.grabup.com/uploads/94805d3ad841ca1e159c8458a9453a4c.png?direct
CCing Dutch localizers.
Can you guys test that on your side? thanks
The translations on that page depend on the preferences you have for Google. If you change them to Dutch all looks well.
I have no preferences for Google. Clean profile. Other locales send the proper information and the start page is localized (like, ko for example).
Google uses your ip / location, so when you use the dutch version in france the startpage will be in french. 

That is what i know, did you also see this behavior in a other translation?
With the cs translation I get this URL: http://cs.start2.mozilla.com/firefox?client=firefox-a&rls=org.mozilla:cs:official

And everything is localized just fine. As I said, ko is the same way. This is the first locale I've seen this on (but I haven't test a bunch of them yet...).
Just tested the 3.0.8. candidate with clean profile and all seems fine for both Dutch and Frisian. Must be something else.
(In reply to comment #4)
> I have no preferences for Google. Clean profile. Other locales send the proper
> information and the start page is localized (like, ko for example).

We have to use the google.com adres and google redirect it to google.nl, ko is using http://www.google.co.kr/ so it will be always translated. 

The nl version is also used in Belgium and they need the be version of google for search
wim as long you are on a dutch ip it will be the dutch google(In reply to comment #7)
> Just tested the 3.0.8. candidate with clean profile and all seems fine for both
> Dutch and Frisian. Must be something else.

wim as long you are on a dutch ip it will be the dutch google
(In reply to comment #6)
> With the cs translation I get this URL:
> http://cs.start2.mozilla.com/firefox?client=firefox-a&rls=org.mozilla:cs:official
> And everything is localized just fine. As I said, ko is the same way. This is
> the first locale I've seen this on (but I haven't test a bunch of them yet...).

When i click on this link it goes to the dutch version :-) (dutch ip)
(In reply to comment #7)
> Just tested the 3.0.8. candidate with clean profile and all seems fine for both
> Dutch and Frisian. Must be something else.

Huh. Weird. They might be using GeoIP stuff for you. I bet en-US takes you to the Dutch version as well.

(In reply to comment #8)
> We have to use the google.com adres and google redirect it to google.nl, ko is
> using http://www.google.co.kr/ so it will be always translated. 
> 
> The nl version is also used in Belgium and they need the be version of google
> for search

Well, for both cs and nl, the URL is still google.com and the language is (or should be...) based on the parameters set. 

cs, for example: http://www.grabup.com/uploads/f95623f429c2bb99ccf273c167a3ff71.png?direct
This could be on Google's end. 

It's good to know that it works fine in Europe. Don't consider this a blocker for release or anything, it just seemed weird because other locales don't do this, afaict.
(In reply to comment #11)
> Well, for both cs and nl, the URL is still google.com and the language is (or
> should be...) based on the parameters set. 
> cs, for example:
> http://www.grabup.com/uploads/f95623f429c2bb99ccf273c167a3ff71.png?direct

No it has to go to the googlesearch of the location where it is used. People in belgium wants to search in belgium or the world, people in south africa want so search in South Africa or the world.
(In reply to comment #12)
> This could be on Google's end. 
> It's good to know that it works fine in Europe. Don't consider this a blocker
> for release or anything, it just seemed weird because other locales don't do
> this, afaict.

try a language that is used in more countries, i think that you will see the same behavior as in the nl version
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
Component: www.mozilla.org/firefox → www.mozilla.org
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.