pango API change broke trunk

RESOLVED DUPLICATE of bug 478871

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 478871
9 years ago
9 years ago

People

(Reporter: Fabien Tassin, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
New pango broke trunk:

g++ -o gfxPangoFonts.o -c -I../../../dist/include/system_wrappers -include ../../../config/gcc_hidden.h -DIMPL_THEBES -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_COM_OBSOLETE -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES  -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux  -I. -I. -I../../../dist/include/cairo -I../../../dist/include/string -I../../../dist/include/pref -I../../../dist/include/xpcom -I../../../dist/include/unicharutil -I../../../dist/include/lcms -I../../../dist/include/locale -I../../../dist/include   -I../../../dist/include/thebes -I/build/buildd/xulrunner-1.9.2-1.9.2~a1~hg20090327r26633+nobinonly/build-tree/mozilla/dist/include/nspr   -I/usr/include  -I/build/buildd/xulrunner-1.9.2-1.9.2~a1~hg20090327r26633+nobinonly/build-tree/mozilla/dist/sdk/include    -fPIC   -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-long-long -pedantic -g -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -Os -freorder-blocks -fno-reorder-functions  -D_REENTRANT -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12   -D_REENTRANT -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12   -D_REENTRANT -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gtk-unix-print-2.0   -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2     -DMOZILLA_CLIENT -include ../../../mozilla-config.h -Wp,-MD,.deps/gfxPangoFonts.pp gfxPangoFonts.cpp
gfxPangoFonts.cpp: In function 'void gfx_pango_font_map_class_init(gfxPangoFontMapClass*)':
gfxPangoFonts.cpp:1841: error: 'struct _PangoFcFontMapClass' has no member named 'context_substitute'
gfxPangoFonts.cpp:1842: error: invalid conversion from 'PangoFcFont* (*)(PangoFcFontMap*, PangoContext*, const PangoFontDescription*, FcPattern*)' to 'PangoFcFont* (*)(PangoFcFontMap*, PangoFcFontKey*)'
make[6]: *** [gfxPangoFonts.o] Error 1
make[6]: Leaving directory `/build/buildd/xulrunner-1.9.2-1.9.2~a1~hg20090327r26633+nobinonly/build-tree/mozilla/gfx/thebes/src'

This happened after the 1.22.4 -> 1.24.0 update.
(https://edge.launchpad.net/ubuntu/+source/pango1.0)

Full logs: http://launchpadlibrarian.net/24419503/buildlog_ubuntu-jaunty-i386.xulrunner-1.9.2_1.9.2~a1~hg20090327r26633%2Bnobinonly-0ubuntu1~umd1_FAILEDTOBUILD.txt.gz/pango

Comment 1

9 years ago
I opened a pango bug about this API breakage: https://bugs.edge.launchpad.net/bugs/349914

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 478871
You need to log in before you can comment on or make changes to this bug.