Closed Bug 485639 Opened 16 years ago Closed 10 months ago

Date.parse is too sensitive to spaces (AM/PM marker)

Categories

(Core :: JavaScript: Standard Library, defect)

x86
Windows XP
defect

Tracking

()

RESOLVED DUPLICATE of bug 449921

People

(Reporter: WeirdAl, Assigned: vinny.diehl)

References

(Blocks 1 open bug, )

Details

(Keywords: testcase)

From a xpcshell test session:

js> Date.parse("Wed Mar 25, 2009 1:56:03 PM PDT")
1238014563000
js> Date.parse("Wed Mar 25, 2009 1:56:03PM PDT")
NaN
Assignee: general → nobody
Component: JavaScript Engine → JavaScript: Standard Library
Severity: normal → S3
See Also: → 449921

My patch for Bug 449921 will fix this.

Assignee: nobody → vinny.diehl
Status: NEW → ASSIGNED

Closing this as the aforementioned patch is about to land.

Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Duplicate of bug: 449921
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.