Closed Bug 485720 Opened 11 years ago Closed 10 years ago

Text Descenders Do Not Display Properly In SeaMonkey Default Theme

Categories

(SeaMonkey :: Themes, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: therubex, Assigned: neil)

References

()

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090327 SeaMonkey/2.0b1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090327 SeaMonkey/2.0b1pre

 
Characters with descenders; [ ] g j p q y
do not display correct in (XP) SeaMonkey /Default Theme/.


Reproducible: Always

Steps to Reproduce:

1.  Open a Find dialog, Ctrl+F
2.  Type in some characters with descenders; [ ] g j p q y

Actual Results:  

Those characters do no display properly.
They're truncated at the bottom.


Expected Results:  
 
Characters with descenders should display properly.



This problem does not occur in the Modern theme.
Preliminary regression range:

10/27/2008 working
11/30/2008 broken
You need to switch the OS theme in Windows XP to Windows Classic to see this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
Attached patch Proposed patchSplinter Review
For some reason XUL layout is miscalculating the height of the textbox if its parent hbox is flexible. In fact, nearly all of the flex attributes in the dialog are bogus, so I removed them too. I also tweaked some align attributes to make the dialog look slightly nicer.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #369886 - Flags: review?(gavin.sharp)
Duplicate of this bug: 525304
Attachment #369886 - Flags: review?(gavin.sharp) → review+
Pushed changeset a15f09d02859 to mozilla-central.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Was this fixed in a theme?  If so, is an end-user release available so that I don't have to wait for the next update of SeaMonkey?
Sorry, but this had to be fixed in content, rather than a theme.
You need to log in before you can comment on or make changes to this bug.