Bottom Border under Column Day Labels is missing.

RESOLVED FIXED in 1.0b1

Status

Calendar
Calendar Views
RESOLVED FIXED
9 years ago
6 years ago

People

(Reporter: dave.r.wilson, Assigned: Decathlon)

Tracking

({polish})

unspecified
1.0b1
polish
Bug Flags:
wanted-calendar1.0 +

Details

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090223 Lightning/1.0pre Thunderbird/3.0b2

Bottom Border under Colum Day Labels is missing in Month and Multiweek Views.

Reproducible: Always




Making the following changes to chrome would fix this problem:

#view-deck .labeldaybox-container
{
  border-bottom: 1px solid #D2D2D2;
}

Comment 1

9 years ago
Could you add a screenshot that shows the issue and a screenshot that shows how it looks with the patch applied?
(Reporter)

Comment 2

9 years ago
Created attachment 372301 [details]
Bottom Border under Colum Day Labels is missing (before patch)
(Reporter)

Comment 3

9 years ago
Created attachment 372304 [details]
Bottom Border under Colum Day Labels displayed (after patch)
Flags: wanted-calendar1.0+
Keywords: polish

Comment 4

9 years ago
confirmed. Looks better, does Christian still do the UI-reviews?
Status: UNCONFIRMED → NEW
Ever confirmed: true
I think this doesn't require an explicit ui-r since its probably rather a regression. Could someone check how things look on the mac and create a patch that fixes the issue?
Whiteboard: [good first bug]
(Assignee)

Comment 6

9 years ago
This bug is a regression from bug 447683. I posted a comment there the seventh of January.
With patch 351864 http://hg.mozilla.org/comm-central/rev/fe713242a103 were deleted some classes and inside calendar-views.css file there are still css rules related to them (that, IMO, should be deleted, but this is another issue).
E.g. classes:
'calendar-month-view-column-header-container' (http://hg.mozilla.org/comm-central/rev/fe713242a103#l4.9);
'month-view-column-header' (the deleted border of this bug);
'calendar-month-view-column-header-label';
are still in calendar-views.css but don't have anymore corresponding names in xml/xul files.
(Assignee)

Comment 7

9 years ago
> 'month-view-column-header' (the deleted border of this bug);

...'calendar-month-view-column-header' (the deleted border of this bug);

Sorry!
(Assignee)

Comment 8

9 years ago
Created attachment 376092 [details] [diff] [review]
patch

As suggested by dave.r.wilson, this patch adds a bottom border to the class 'labeldaybox-container'.
I can't verify how it looks on a mac.

I have to say that you get the same result adding a bottom border to 'calendar-day-label' (top and left borders of every column header are defined with this class. The border on extreme right, instead, is defined with 'labeldaybox-container' class):

 calendar-day-label {
     color: #000000;
     background-color: white;
     background-image: url("chrome://calendar/skin/calendar-day-label-back.png");
     border-left: 1px solid #D2D2D2;
     border-top: 1px solid #D2D2D2;
+    border-bottom: 1px solid #D2D2D2;
 }

don't know what's better.
Attachment #376092 - Flags: review?(philipp)
Assignee: nobody → bv1578
Status: NEW → ASSIGNED
Attachment #376092 - Flags: review?(philipp) → review?(dbo.moz)
Comment on attachment 376092 [details] [diff] [review]
patch

Daniel, can you take a look if this works as expected on a mac?
Summary: Bottom Border under Colum Day Labels is missing. → Bottom Border under Column Day Labels is missing.
OS: Windows Vista → All
Hardware: x86 → All
Comment on attachment 376092 [details] [diff] [review]
patch

sorry for delay..

looks good; r=dbo
Attachment #376092 - Flags: review?(dbo.moz) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/9ee52aa76e76>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Whiteboard: [good first bug]
Target Milestone: --- → 1.0
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.