Reminder based on end/due date changes to start date after restart (RELATED property missing in VALARM component)

VERIFIED FIXED in 1.0b1

Status

--
major
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: ssitter, Assigned: Fallen)

Tracking

({regression})

Trunk
1.0b1
regression
Bug Flags:
blocking-calendar1.0 +
in-testsuite +

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090331 Calendar/1.0pre

Steps to Reproduce:
1. Start with clean profile
2. Create new event with a custom alarm "15 minutes before the event ends"
3. Check VALARM component after exporting or copying the event

Actual Results:
RELATED property missing in VALARM component.

If created with Sunbird 1.0pre (2009033105):
    BEGIN:VALARM
    ACTION:DISPLAY
    TRIGGER;VALUE=DURATION:-PT15M
    DESCRIPTION:Default Mozilla Description
    END:VALARM

If created with Sunbird 0.9:
    BEGIN:VALARM
    TRIGGER;VALUE=DURATION;RELATED=END:-PT15M
    DESCRIPTION:Mozilla Alarm: New Event
    ACTION:DISPLAY
    END:VALARM

Tested with storage and ics provider.
Flags: blocking-calendar1.0?
(Reporter)

Comment 1

10 years ago
Regression range: Works in Sunbird 1.0pre (20090115031904)
                  Fails in Sunbird 1.0pre (20090116032231)

Checkins during regression range: <https://hg.mozilla.org/comm-central/pushloghtml?startdate=2009-01-15+03:19:04&enddate=2009-01-16+03:22:31>

Seems to be regressed by Bug 471973.
Blocks: 471973
(Reporter)

Comment 2

10 years ago
Created attachment 370280 [details] [diff] [review]
xpcshell testcase
Attachment #370280 - Flags: review?(philipp)
(Reporter)

Updated

10 years ago
Attachment #370280 - Attachment description: xpshell testcase → xpcshell testcase
Flags: in-testsuite?
(Assignee)

Comment 3

10 years ago
Comment on attachment 370280 [details] [diff] [review]
xpcshell testcase

r=philipp if you move this into test_alarm.js. I don't think we need an extra file for this?
Attachment #370280 - Flags: review?(philipp) → review+
(Reporter)

Comment 4

10 years ago
I prefer the way used in other parts of mozilla - use a separate file for each test if possible - because |make check| reports what file failed. Using one big single test file requires additional work, e.g. by adding dump() statements, if you want to know on what specific test it failed.
(Assignee)

Comment 5

10 years ago
In that case, maybe we should use subfolders for categories, i.e

test/unit
 +-alarms
   --test_bug486186.js
 +-providers
   --...

I'm fine with using flat folders for now though so go ahead and check it in.
(Reporter)

Comment 6

10 years ago
Changing summary to describe the user error instead of the technical error.
Summary: RELATED property missing in VALARM component after event creation → Reminder based on end/due date changes to start date after restart (RELATED property missing in VALARM component)
(Assignee)

Updated

10 years ago
Flags: blocking-calendar1.0? → blocking-calendar1.0+
(Assignee)

Updated

9 years ago
Assignee: nobody → philipp
(Assignee)

Comment 7

9 years ago
Created attachment 374250 [details] [diff] [review]
Fix - v1
Attachment #374250 - Flags: review?(ssitter)
Status: NEW → ASSIGNED
(Reporter)

Updated

9 years ago
Attachment #374250 - Flags: review?(ssitter) → review+
(Reporter)

Comment 8

9 years ago
Comment on attachment 374250 [details] [diff] [review]
Fix - v1

r=ssitter
(Assignee)

Comment 9

9 years ago
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/07de5fc8cd8e>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 1.0
(Reporter)

Comment 10

9 years ago
Comment on attachment 370280 [details] [diff] [review]
xpcshell testcase

Pushed to comm-central: <https://hg.mozilla.org/comm-central/rev/807e2a2ae5e4>
(Reporter)

Updated

9 years ago
Flags: in-testsuite? → in-testsuite+
(Reporter)

Comment 11

9 years ago
Verified fixed using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090611 Calendar/1.0pre (BuildID: 20090611031611)
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.