If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

reftest for 480267 fails on 1.9.1 branch due to early onload firing

RESOLVED DUPLICATE of bug 477880

Status

()

Core
CSS Parsing and Computation
--
major
RESOLVED DUPLICATE of bug 477880
9 years ago
9 years ago

People

(Reporter: jtd, Unassigned)

Tracking

1.9.1 Branch
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
As part of the fix for bug 480267 I created a reftest that compares pages with a large set of downloadable fonts under different style/weight settings.  The test renders fine both on trunk and on 1.9.1 with the patch but it's failing under the reftest harness because the onload handler for the test page is firing early, causing the wrong snapshot to be taken and aborting the font downloads on the test page.  I'm going to mark the test random for now.

Steps:

1. Enable downloadable font logging:

  export NSPR_LOG_MODULES=userfonts:5,fontdownloader:5

2. Run reftests in reftests/font-face directory

Result: the last test, synthetic-weight-style.html will fail and the images will show the test page rendered without downloadable fonts

To view the tests (due to access controls need HTTP load):

http://people.mozilla.org/~jdaggett/font-face/synthetic-weight-style.html
http://people.mozilla.org/~jdaggett/font-face/synthetic-weight-style-ref.html
John, does applying the patch for bug 477880 help?  Maybe we should backport that to branch....
(Reporter)

Updated

9 years ago
Blocks: 480267
(Reporter)

Comment 2

9 years ago
Yup, that was it!
Depends on: 477880
(Reporter)

Comment 3

9 years ago
Pushing 477880 to 1.9.1 fixes this.  Will remove 'random' from reftest as part of fix for bug 468387, which also affects the reftest on Windows.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 477880
You need to log in before you can comment on or make changes to this bug.