Investigate Chrome registration failed messages on every startup

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
RESOLVED INVALID
9 years ago
5 months ago

People

(Reporter: Cww, Unassigned)

Tracking

({common-issue+})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Lots of users are reporting that they get Chrome registration failed messages after updating and at every startup.  Per bug 401769, the solutions include disabling the faulty extension(s) and/or running as an administrator once.

However the warning is particularly not helpful and confusing so this is a bug to take a look at the causes of this message (it's pretty common) and to resolve either by addressing those or providing a more useful dialog/warning.

Comment 1

9 years ago
(In reply to comment #0)
> However the warning is particularly not helpful and confusing so this is a bug
> to take a look at the causes of this message (it's pretty common) and to
> resolve either by addressing those or providing a more useful dialog/warning.

See also bug 302527
Rob, could you follow up with Cheng on this?
If we are seeing spikes after app update I suspect we may have old extensions hanging about that haven't been cleaned up properly.

Dave, I'd like to get your thoughts on this.
That the error goes away when running as administrator suggests that the user has some extensions installed that they do not have write access to. Firefox will be trying to write a chrome.manifest file out for them and failing. We could I guess get rid of the warning in that case, but then that warning is gone in 3.6 anyway.

I'm not totally sure why this would cluster around app update unless maybe we end up re-registering all extensions at that time, though that shouldn't normally happen.
(Reporter)

Comment 6

9 years ago
This seems predominantly vista if it helps any... got a bunch of these this week as well but probably a result of the 3.5.5 updated.
Cww, if you could zip up your extensions directory and send them to me at rstrong at mozilla dot com it might provide a clue as to the cause. Thanks.

Comment 8

5 months ago
Legacy extensions are no longer valid in Firefox 57, closing.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.