Closed Bug 486531 Opened 16 years ago Closed 16 years ago

[XHR progress events] Progress handler not called if set after open()

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 311425

People

(Reporter: sylvain.pasche, Unassigned)

References

Details

I spent some time debugging why progress events weren't working in an extension. It turns out that I was setting the onprogress handler handler after open() was called. When you do this, the handlers are not called at all and there's no exception or error raised. I'm not sure what the spec says about it, but if this is not allowed it would be nice to have at least some sort of feedback.

Testcase:
Start from:
http://mozilla.pettay.fi/xhr_upload/xhr_upload_demo.html
Put the line with 
        xhr.open("POST", "cgi-bin/posthandler.pl");
before the lines setting the onprogress handlers.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.