SeaMonkey: Passwords are not saved when autocomplete="off"

RESOLVED DUPLICATE of bug 956906

Status

SeaMonkey
Passwords & Permissions
RESOLVED DUPLICATE of bug 956906
9 years ago
4 years ago

People

(Reporter: Boris 'pi' Piwinger, Unassigned)

Tracking

({meta})

Trunk
x86
Windows Vista
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090223 SeaMonkey/2.0a3

On my homebanking account (https://ebanking.easybank.at/InternetBanking/EASYBANK_webbank_de.html) I had my login saved. After converting my SM1 profile it was replaced by wrong data. So I deleted the old entry and tried to save a new one. But there is no question to save it. So we have a regression.

pi
(Reporter)

Comment 1

9 years ago
Same bug on https://www.cortalconsors.de/euroWebDe/- :-( That makes the browser useless.
(Reporter)

Comment 2

9 years ago
Additional finding: The login is not saved, but the account number is.
The page https://www.cortalconsors.de/euroWebDe/ has set autocomplete="off" for the password field.
On https://ebanking.easybank.at/InternetBanking/EASYBANK_webbank_de.html it does not save anything at all right?
(Reporter)

Comment 4

9 years ago
Both pages behave the same, so both save the account number.

I have set:
user_pref("wallet.crypto.autocompleteoverride", true);

pi
autocompleteoverride does currently not work, see Bug 425145. Here saving the password (PIN) on https://ebanking.easybank.at/InternetBanking/EASYBANK_webbank_de.html works for me: I enter any account data, click on login and then the info bar at the top asks me if I want to save the password for the username I entered.

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 425145

Updated

9 years ago
Status: RESOLVED → REOPENED
Depends on: 425145
Resolution: DUPLICATE → ---

Updated

9 years ago
Status: REOPENED → NEW
(Reporter)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 425145
V.Duplicate, confirming comment 3 and comment 5.
Status: RESOLVED → VERIFIED

Comment 9

5 years ago
UnDUPing and repurposing this to track patches landing in mozilla-central

Toolkit: Bug 425145 - User Option to Save ID and Password When autocomplete="off"
Firefox: Bug 951981 - Expose signon.autocompleteOverride in the preferences
Status: VERIFIED → REOPENED
Component: Security → Passwords & Permissions
Resolution: DUPLICATE → ---
See Also: → bug 951981
Summary: Password not saved → SeaMonkey: Passwords are not saved when autocomplete="off"

Updated

5 years ago
Status: REOPENED → NEW

Updated

5 years ago
Depends on: 952143
Keywords: regression → meta

Comment 10

5 years ago
(In reply to Boris 'pi' Piwinger from comment #4)
> Both pages behave the same, so both save the account number.
> 
> I have set:
> user_pref("wallet.crypto.autocompleteoverride", true);

Should we migrate "wallet.crypto.autocompleteoverride" to "signon.autocompleteOverride"
q.v. Attachment 401438 [details] [diff]

Comment 11

4 years ago
FIXED by Firefox bug 956906.
Status: NEW → RESOLVED
Last Resolved: 9 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 956906
You need to log in before you can comment on or make changes to this bug.