If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

URL History Cannot Be Cleared By Any Means

VERIFIED INVALID

Status

()

Firefox
Address Bar
VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: scorpgalweb, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8

     I am using Firefox 3.0.8 for Windows XP.  I cannot clear the URL history from the URL bar by any means.  I have tried the following:
1)Uncheck "Keep my history for (X) number of days".
2)Check "Keep my history of (X) number of days" and set value to zero.
3)Set the Options so that Private Data is cleared each time Firefox is closed.
4)Manually select "Clear Private Data" from the Tools menu.
5)Go to Control Panel in Windows XP.  Clear all browsing history.
   None of the above works.  The problem began with Firefox 3.
    

Reproducible: Always

Steps to Reproduce:
1.Browse
2.Set Firefox to clear Private Data upon closing and not to keep any history at all. 
3. Manually clear Private Data.
4. Close and re-open Firefox.
5. Left click on down arrow to view URL history in URL bar.

Actual Results:  
URL history not cleared.

Expected Results:  
URL history should be cleared.

The offending URL history seems to be a combination of sites I recently visited and sites that I have bookmarked.

Comment 1

9 years ago
In 3.0 and 3.1 the URL history can be cleared by left-clicking the down arrow, hovering over the entry, and pressing delete.  Tedious and a bad solution, yes, but a solution nonetheless until somebody comes up with a better one.

In 3.1, with private browsing enabled, it doesn't keep the URL history.
So, the addresses that are in the address bar are bookmarks? This is correct behavior in Firefox 3.0. The bookmarks are not cleared when you choose clear private data. If you use firefox 3.1b3 or later, you can select, from the privacy tab in options, what you want to appear in the address bar.
Severity: major → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Component: General → Location Bar and Autocomplete
QA Contact: general → location.bar
Resolution: --- → INVALID
Version: unspecified → 3.0 Branch
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.