Password not saved at blogger.com

VERIFIED INVALID

Status

VERIFIED INVALID
10 years ago
10 years ago

People

(Reporter: gnm, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.21) Gecko/20090327 Camino/1.6.7 (like Firefox/2.0.0.21pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.21) Gecko/20090327 Camino/1.6.7 (like Firefox/2.0.0.21pre)

Despite 'checking' the relevant "Remember Me"check-box each time I log-in to Blogger, I have to manually enter the details each time I return. This does not occur at other sites. Is this a Camino issue or a site issue?

Reproducible: Always

Steps to Reproduce:
1. Establish a Blogger account
2. Log-in with appropriate username (valid email address) and password
3. Check "Remember Me" check-box
4. Log out
5. Navigate away from site
6. Return to site: No recognition occurs - neither username or password
Actual Results:  
As no username or password appear, they must be entered manually each time.

Expected Results:  
I expected that each time I directed my computer to the stated URL, my username and password would appear automatically and I would only have to click the "Login" button - as occurs at other sites.

Comment 1

10 years ago
Are you accepting cookies from said site? That's the usual mechanism by which "Remember Me" features work, and if you're either blocking cookies specifically from that site or (more rarely) blocking third-party cookies, you're probably going to break that feature.

cl
(Reporter)

Comment 2

10 years ago
I had cookies set at "Accept cookies only from sites that I visit". On the possibility that since I use the overall Google username/password to access Blogger, Blogger was registered with my computer as a third-party, I changed settings (in Preferences) to "Accept all cookies". But there has been no change in behaviour … the "Remember Me" feature for this site does not work.

Comment 3

10 years ago
It's also possible that a cookie for Blogger or Google has gotten "stuck" at some bad value, so you should clear all your Blogger and Google cookies and try it again.

Comment 4

10 years ago
You should also check your cookie blacklist, since that overrides the default setting.
(Reporter)

Comment 5

10 years ago
In response to comments #3 & #4: I went through cookie list and deleted any that referred to Google or Blogger (or anything to do with "blog"); there are no entries in my cookie blocking list.  "Remember me" still does not work for this site … should I delete all cookies - start fresh?

Comment 6

10 years ago
I just read the report more carefully.

(In reply to comment #0)
> I expected that each time I directed my computer to the stated URL, my username
> and password would appear automatically and I would only have to click the
> "Login" button - as occurs at other sites.

This is not what Remember Me does. That's Camino's password saving. "Remember Me" means that if you leave the site and come back you shouldn't need to log in again, but you are explicitly logging out in step 4, thus defeating that.

Your real issue has nothing to do with Remember Me, but the fact that Camino isn't offering to save your login information for blogger.com. The reason for that is that their login form has 'autocomplete="off"' set for it, which is an explicit instruction to browsers not to offer to save the password in their password managers.

It's stupid that Blogger's form sets this, but given that it's there Camino is behaving correctly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
Summary: "Remember Me" at this site does not work, but does at others. → Password not saved at blogger.com
(Reporter)

Comment 7

10 years ago
Aah, thanks for the comprehensive description.

Comment 8

10 years ago
By the way, you can set wallet.crypto.autocompleteoverride to 'true' in about:config if you want to work around their limitation.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.