Remove Yahoo! JAPAN search suggest parameter

RESOLVED FIXED

Status

defect
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: kohei, Assigned: kev)

Tracking

({fixed1.9.0.12, productization})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Posted patch diff (obsolete) — Splinter Review
+++ This bug was initially created as a clone of Bug #450367 +++

Yahoo! JAPAN team asked us to add a parameter (Application ID) to the Yahoo! JAPAN search suggest API which came with our ja/ja-JP-mac builds.

http://mxr.mozilla.org/l10n-central/source/ja/browser/searchplugins/yahoo-jp.xml
http://mxr.mozilla.org/l10n-central/source/ja-JP-mac/browser/searchplugins/yahoo-jp.xml

http://developer.yahoo.com/faq/#appid
Attachment #371664 - Flags: review?(l10n)
Attachment #371664 - Flags: approval1.9.0.10?
Keywords: productization
Comment on attachment 371664 [details] [diff] [review]
diff

Moving the review over to stas.
Attachment #371664 - Flags: review?(l10n) → review?(stas)
Whiteboard: needs review
Comment on attachment 371664 [details] [diff] [review]
diff

Technically, this is OK. Over to Kev for his review.

Kev, is the ID correct?
Attachment #371664 - Flags: review?(stas)
Attachment #371664 - Flags: review?(kev)
Attachment #371664 - Flags: review+
wrt whether or not the app id is correct, I have no idea. Kohei, where did it come from?

wrt whether or not we want to include this, I think it'll require legal review. I was under the impression that the use of the suggested search results was at Yahoo!'s request, and that it was not governed by the APIs TOU. The implication here seems to be that the search suggest is bound by the TOU of the API, and we may need to review those terms and determine if we can comply with them.

I'll discuss with Harvey this morning, but if this is a requirement for the search suggest function, then it affects the product as a whole, and not just Y! Japan.
We've got the appid directly from Y! Japan team, so it should be okay.
Ok. I've asked Margaret to clarify with Yahoo! whether the suggested search included with the Yahoo! plugins are covered by the TOU (http://info.yahoo.com/legal/us/yahoo/api/api-2140.html) or not. If they are, we have to determine whether we can accept them or not, and go from there. If they are not, we have to determine if we'd include this information, which is similar to the "fr" codes we include with search requests. If we do include the appid on suggested searches, it should be product wide (e.g. all locales) with a single appid.
Thanks Kev. Looking forward to hearing from Yahoo! on this. I'll be happy to lead this if a global change across all locales is required.
(In reply to comment #5)
Yahoo! Japan has a separate TOU. We'll discuss this with YJ team.
http://developer.yahoo.co.jp/terms/
why'd they ref the yahoo.com tou, then?
actually, doesn't matter. it's still something which we'd have to make the determination on whether we could meet or not. working on it with legal as well. please update the bug with info you find. thanks, Kohei!
Hello Kev, Yahoo!Japan is waiting for any reply from Mozilla about the issue.
Do you have any update information ?
Hello all,

 I have conversation with an Yahoo! Japan engineer who takes care of
the issue.He suggests that the issue is a critical thing for Firefox
ja users and it should be fixed as soon as possible.
 The reason why he does is because, Yahoo Japan has a separate system
for suggest search for Japanese users and the system will be revised
as a new version soon. At that time, all suggest requests need specific
Y!J appid. If there isn't, any request without the id would be rejected
and the web browser can't get and show any suggest information to the
users.

 He thinks that June period is the best timing of the implementation
for Firefox.

Anyway, Yahoo! Japan will do escalation to Y! corp about the issue,
and maybe something from Y!J will be coming soon.
Comment on attachment 371664 [details] [diff] [review]
diff

This has missed 1.9.0.11. Pushing to 1.9.0.12.
Attachment #371664 - Flags: approval1.9.0.11? → approval1.9.0.12?
 I have talked with Y!Japan people. The company understands 3.0.11 will be never
applied the implementation. It should be focused on the next version 3.0.12.
Anyway, Y!J tries to do escalation via Y!inc about the issue with the next version, so someone at MoCo will receive any request about the issue from Y!inc side.

-Shigeru Yoshitake
Shigeru,

I'll be talking to Y! Corporate about it later today. Could you please find out a few more details from Y! Japan, as they have not heard anything to date. The information I'm looking for is:

- who the AppID owner is. If it's Yahoo! JAPAN, we'll have to register our own if we need to implement.
- whether or not the search suggest URL will change and, if so, what the new URL will be
- clarification on whether or not the change Yahoo! JAPAN is talking about is a move to the Search BOSS API.

I'll be speaking with Y! Corp this aft to discuss the change, and any implications it may have for us. The major discussion point for me will be around whether it's implied that we agree to the Terms as-is, because there are a few attribution clauses we don't adhere to (and probably can't).

More to come, but if you could ask for clarification on the above three points, that'd be much appreciated.
Shigeru, any updates here? I have spoken with Y! Corp., but they are unaware of any issue/escalation.

The situation is unique to Yahoo! JAPAN, as they make the search suggest available under their API servers. Yahoo! Corp. has a different suggest URI (under ff.search.yahoo.com) that is not part of the API services.

The only question I have is whether or not Y! JAPAN's expectation on whether or not we are bound by the terms and conditions of the Y! JAPAN API program. If we are, we'll probably need to remove the search suggest, as we can't meet some of the conditions (i.e. attribution). If we are not, then I don't see an issue in making this change in the JA locale. Kohei references the Ts & Cs in comment #1, and I'm not sure if that is for compliance or just an overview of the AppID. If we could get clarification on this, as well as the questions in comment #14, I'd appreciate it.

Following that, we can get this change in quickly, one way or the other.

Thanks!

kev
Kev,

Here are answers from Y!J.

> - who the AppID owner is. If it's Yahoo! JAPAN, 
> we'll have to register our ownif we need to implement

It's Y!J, so we will have to register it by ourselves.
You're correct, the system is independent from Y!inc,
so we should think Mozilla Corp needs to consider a company
separate from Y!inc.

> - whether or not the search suggest URL will change and,
> if so, what the new URL will be

When new system is coming, the url would be changed to new one,
and it isn't fixed yet now. But it takes to keep an existing
host for a while to current users..

> - clarification on whether or not the change Yahoo! JAPAN is
> talking about is a move to the Search BOSS API.

There is no plan to proceed the API in Y!J.

Regarding Ts & Cs questions from you, I'll check it out again.

-Shigeru Yoshitake
Kev,

There are two T&C of Y!J in Japanese, unfortunately no English version.

http://developer.yahoo.co.jp/terms/
http://docs.yahoo.co.jp/docs/info/terms/

If you concern of the specific issues with it, please let me know.
I'll check it out for you in those urls.

-shigeru
Hello Kev,

I got a message with the issue from Y!J.

Y!J has a plan to migrate to new system including suggest function for
Firefox Ja search. The deadline is July 17th and it's impossible to
change the schedule anymore.  
The date is very close for Japan team and the team would like to resolve
the problem ASAP. 

How should we proceed the next step ?
Please share your thought and idea to fix the problem.

Best regards.
-Shigeru Yoshitake
Kev, repoke on this one. We have to wrap up .12 quickly.
Kev: What's the word? We need to freeze for .12 by Sunday evening.
ss, I'm under the impression Kev is away on vacation this weekend?
en vacances, but checking email. sorry, meant to respond to this yesterday.

At this point, we have to take it out. I've had a few emails back and forth offline with Shigeru and, from what I understand, use of the API key us an implicit agreement to the terms of use of the Yahoo! JAPAN API. We cannot meet the attribution requirements in the product, and do not accept some of the terms in the TOU. Without a written exception from Yahoo! JAPAN, we can't really include the key because of the implicit acceptance.

I'm hopeful Yahoo! JAPAN will grant us an exception to the TOU acceptance for search suggest but, from what I understand from Shigeru, it's not something we have at this time. It should be noted that this is the only search provider - including Yahoo! Corporate (I know it's a different entity) that I am aware of who is requiring acceptance of like terms for something like search suggest. 

I don't see any issue with including the key when we have the exception, but until we do, we'll have to remove search suggest from the plugin. I'll attach a patch shortly, and we should apply this to both 1.9.0.x and 1.9.1.x
Attached is the patch to the yahoo-jp.xml to remove search suggest. Note that this patch also removes the "rls" parameter from the search, which is Google-specific and shouldn't be passed along (Kohei, please confirm that RLS is not a requirement, it shouldn't be from what I see in the docs)
Attachment #371664 - Attachment is obsolete: true
Attachment #386809 - Flags: review?
Attachment #371664 - Flags: review?(kev)
Attachment #371664 - Flags: approval1.9.0.12?
Attachment #386809 - Flags: review? → review?(stas)
Comment on attachment 386809 [details] [diff] [review]
Yahoo! JAPAN Search Plugin w/Suggest Removed

r=me. Please land this patch on both branches (1.9.0, 1.9.1) and trunk (l10n-central) using a descriptive check-in comment, mentioning the bug number and my review (e.g. "Bug 487407: Remove search suggest from Yahoo! JAPAN search plug-in, p=kev, r=stas").

Please use fixed1.9.0.x and verified1.9.0.x keywords in this bug to track landing and verification on the 1.9.0.x branch. The same goes for the 1.9.1 branch (fixed1.9.1, verified1.9.1).

Thanks.
Attachment #386809 - Flags: review?(stas) → review+
Whiteboard: needs review
Attachment #386809 - Flags: approval1.9.0.12+
Thanks Kev.

This needs landing in the next 8 hours if it's going to make 1.9.0.12.
Assignee: kohei.yoshino.bugs → kev
Summary: Add a parameter to the Yahoo! JAPAN search suggest API → Remove Yahoo! JAPAN search suggest parameter
Landed in CVS:

ja:
Checking in browser/searchplugins/yahoo-jp.xml;
/l10n/l10n/ja/browser/searchplugins/yahoo-jp.xml,v  <--  yahoo-jp.xml
new revision: 1.4; previous revision: 1.3
done

ja-JP-mac:
Checking in browser/searchplugins/yahoo-jp.xml;
/l10n/l10n/ja-JP-mac/browser/searchplugins/yahoo-jp.xml,v  <--  yahoo-jp.xml
new revision: 1.4; previous revision: 1.3
done

Sam, can you still take it for 1.9.0.12?

We still need landings on hg.
Keywords: fixed1.9.0.12
Yep. This made 1.9.0.12. Thanks for landing it Staś!
The search suggest is still included in Firefox 3.5.x, 3.6 betas and trunk! The feature doesn't work because the Yahoo! server returns an error message, but we have to remove the suggest code asap.
Really unfortunately I haven't heard about this and the patch was landed only on 1.9.0.x CVS repo. I'll land this change to all hg repos soon.

I'll close this bug once I land this change to all hg repos.
landed on 1.9.1, 1.9.2 and central.
 -> resolved fixed.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.