TM: shutdown leak of rt->builtinFunctions

RESOLVED FIXED in mozilla1.9.1b4

Status

()

P3
normal
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: brendan, Assigned: brendan)

Tracking

({fixed1.9.1, memory-leak, regression})

Trunk
mozilla1.9.1b4
fixed1.9.1, memory-leak, regression
Points:
---
Bug Flags:
wanted1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-in-tracemonkey)

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
Created attachment 372250 [details] [diff] [review]
fix

The patch in bug 487191 is really for an unreported bug, shutdown leak due to not clearing rt->builtinFunctions before last GC. Easy fix.

/be
Attachment #372250 - Flags: review?(jorendorff)
Flags: wanted1.9.1?
(Assignee)

Updated

10 years ago
Summary: Shutdown leak of rt->builtinFunctions → TM: shutdown leak of rt->builtinFunctions
Comment on attachment 372250 [details] [diff] [review]
fix

Oops.  Thanks for fixing this.
Attachment #372250 - Flags: review?(jorendorff) → review+
(Assignee)

Comment 2

10 years ago
Fixed in tm:

http://hg.mozilla.org/tracemonkey/rev/bbe2f2403eab

/be
Status: NEW → ASSIGNED
Priority: -- → P3
Whiteboard: fixed-in-tracemonkey

Updated

10 years ago
Flags: wanted1.9.1? → wanted1.9.1+

Comment 3

10 years ago
http://hg.mozilla.org/mozilla-central/rev/bbe2f2403eab
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.